An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and…
Priority LOW 29CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The current implementation of CSRF protection in Symfony (Version >=2) does not use different tokens for HTTP and HTTPS; therefore the token is subject to MITM attacks on HTTP and can then be used in an HTTPS context to do CSRF attacks.
Why it matters now
EPSS 0.01486 74th percentileScored 2026-11-07
Fix Fixed symfony/security-csrf (Packagist): 2.7.38, 2.8.31, 3.2.14 +1symfony/security (Packagist): 2.7.38, 2.8.31, 3.2.14 +1+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | symfony/security-csrf (Packagist) | 2.7.0 to before 2.7.38 | 2.7.38 | Patch available | GHSA-92x6-h2gr-8gxq |
| — | symfony/security-csrf (Packagist) | 2.8.0 to before 2.8.31 | 2.8.31 | Patch available | GHSA-92x6-h2gr-8gxq |
| — | symfony/security-csrf (Packagist) | 3.0.0 to before 3.2.14 | 3.2.14 | Patch available | GHSA-92x6-h2gr-8gxq |
| — | symfony/security-csrf (Packagist) | 3.3.0 to before 3.3.13 | 3.3.13 | Patch available | GHSA-92x6-h2gr-8gxq |
| — | symfony/security (Packagist) | 2.7.0 to before 2.7.38 | 2.7.38 | Patch available | GHSA-92x6-h2gr-8gxq |
| — | symfony/security (Packagist) | 2.8.0 to before 2.8.31 | 2.8.31 | Patch available | GHSA-92x6-h2gr-8gxq |
| — | symfony/security (Packagist) | 3.0.0 to before 3.2.14 | 3.2.14 | Patch available | GHSA-92x6-h2gr-8gxq |
| — | symfony/security (Packagist) | 3.3.0 to before 3.3.13 | 3.3.13 | Patch available | GHSA-92x6-h2gr-8gxq |
| — | symfony/symfony (Packagist) | 2.7.0 to before 2.7.38 | 2.7.38 | Patch available | GHSA-92x6-h2gr-8gxq |
| — | symfony/symfony (Packagist) | 2.8.0 to before 2.8.31 | 2.8.31 | Patch available | GHSA-92x6-h2gr-8gxq |
| — | symfony/symfony (Packagist) | 3.0.0 to before 3.2.14 | 3.2.14 | Patch available | GHSA-92x6-h2gr-8gxq |
| — | symfony/symfony (Packagist) | 3.3.0 to before 3.3.13 | 3.3.13 | Patch available | GHSA-92x6-h2gr-8gxq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- symfony/security-csrf (Packagist) Vendor— Affected 2.7.0 to before 2.7.38 Fixed in 2.7.38 Patch available GHSA-92x6-h2gr-8gxq
- symfony/security-csrf (Packagist) Vendor— Affected 2.8.0 to before 2.8.31 Fixed in 2.8.31 Patch available GHSA-92x6-h2gr-8gxq
- symfony/security-csrf (Packagist) Vendor— Affected 3.0.0 to before 3.2.14 Fixed in 3.2.14 Patch available GHSA-92x6-h2gr-8gxq
- symfony/security-csrf (Packagist) Vendor— Affected 3.3.0 to before 3.3.13 Fixed in 3.3.13 Patch available GHSA-92x6-h2gr-8gxq
- symfony/security (Packagist) Vendor— Affected 2.7.0 to before 2.7.38 Fixed in 2.7.38 Patch available GHSA-92x6-h2gr-8gxq
- symfony/security (Packagist) Vendor— Affected 2.8.0 to before 2.8.31 Fixed in 2.8.31 Patch available GHSA-92x6-h2gr-8gxq
- symfony/security (Packagist) Vendor— Affected 3.0.0 to before 3.2.14 Fixed in 3.2.14 Patch available GHSA-92x6-h2gr-8gxq
- symfony/security (Packagist) Vendor— Affected 3.3.0 to before 3.3.13 Fixed in 3.3.13 Patch available GHSA-92x6-h2gr-8gxq
- symfony/symfony (Packagist) Vendor— Affected 2.7.0 to before 2.7.38 Fixed in 2.7.38 Patch available GHSA-92x6-h2gr-8gxq
- symfony/symfony (Packagist) Vendor— Affected 2.8.0 to before 2.8.31 Fixed in 2.8.31 Patch available GHSA-92x6-h2gr-8gxq
- symfony/symfony (Packagist) Vendor— Affected 3.0.0 to before 3.2.14 Fixed in 3.2.14 Patch available GHSA-92x6-h2gr-8gxq
- symfony/symfony (Packagist) Vendor— Affected 3.3.0 to before 3.3.13 Fixed in 3.3.13 Patch available GHSA-92x6-h2gr-8gxq
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 2.7.0 – 2.7.37; 3.2.0 – 3.2.13; 3.3.0 – 3.3.12; 3.8.0 – 3.8.30 | Vulnerable | sensiolabs |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.7.0 – 2.7.37; 3.2.0 – 3.2.13; 3.3.0 – 3.3.12; 3.8.0 – 3.8.30 Vulnerable ·sensiolabs
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-92x6-h2gr-8gxq symfony/security-csrf (Packagist) Fixed in 2.7.38 Advisory →
- Fix · GHSA-92x6-h2gr-8gxq symfony/security-csrf (Packagist) Fixed in 2.8.31 Advisory →
- Fix · GHSA-92x6-h2gr-8gxq symfony/security-csrf (Packagist) Fixed in 3.2.14 Advisory →
- Fix · GHSA-92x6-h2gr-8gxq symfony/security-csrf (Packagist) Fixed in 3.3.13 Advisory →
- Fix · GHSA-92x6-h2gr-8gxq symfony/security (Packagist) Fixed in 2.7.38 Advisory →
- Fix · GHSA-92x6-h2gr-8gxq symfony/security (Packagist) Fixed in 2.8.31 Advisory →
- Fix · GHSA-92x6-h2gr-8gxq symfony/security (Packagist) Fixed in 3.2.14 Advisory →
- Fix · GHSA-92x6-h2gr-8gxq symfony/security (Packagist) Fixed in 3.3.13 Advisory →
- Fix · GHSA-92x6-h2gr-8gxq symfony/symfony (Packagist) Fixed in 2.7.38 Advisory →
- Fix · GHSA-92x6-h2gr-8gxq symfony/symfony (Packagist) Fixed in 2.8.31 Advisory →
- Fix · GHSA-92x6-h2gr-8gxq symfony/symfony (Packagist) Fixed in 3.2.14 Advisory →
- Fix · GHSA-92x6-h2gr-8gxq symfony/symfony (Packagist) Fixed in 3.3.13 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16653
- 2026-10-03 Alias added: GHSA-92x6-h2gr-8gxq
References
Advisory 4
Other 6
- https://github.com/symfony/symfony/commit/b4dbdd7cd8732483d585eacff3428c16b07ad15e
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-csrf/CVE-2017-16653.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security/CVE-2017-16653.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2017-16653.yaml
- https://github.com/symfony/symfony
- https://symfony.com/cve-2017-16653
Sources
- CVE-2017-16653 · CVE Program
- CVE-2017-16653 · NVD
- FIRST EPSS
- GHSA-92x6-h2gr-8gxq · GitHub Advisory Database · CC BY 4.0
- CVE-2017-16653 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences