An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The Intl component includes various bundle readers that are used to read resource bundles from the local filesystem. The read() methods of these classes use a path and a locale to determine the language bundle to retrieve. The locale argument value is commonly retrieved from untrusted user input (like a URL parameter). An attacker can use this argument to navigate to arbitrary directories via the dot-dot-slash attack, aka Directory Traversal.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | symfony/intl (Packagist) | 2.7.0 to before 2.7.38 | 2.7.38 | Patch available | GHSA-c49r-8gj6-768r |
| — | symfony/intl (Packagist) | 2.8.0 to before 2.8.31 | 2.8.31 | Patch available | GHSA-c49r-8gj6-768r |
| — | symfony/intl (Packagist) | 3.0.0 to before 3.2.14 | 3.2.14 | Patch available | GHSA-c49r-8gj6-768r |
| — | symfony/intl (Packagist) | 3.3.0 to before 3.3.13 | 3.3.13 | Patch available | GHSA-c49r-8gj6-768r |
| — | symfony/symfony (Packagist) | 2.7.0 to before 2.7.38 | 2.7.38 | Patch available | GHSA-c49r-8gj6-768r |
| — | symfony/symfony (Packagist) | 2.8.0 to before 2.8.31 | 2.8.31 | Patch available | GHSA-c49r-8gj6-768r |
| — | symfony/symfony (Packagist) | 3.0.0 to before 3.2.14 | 3.2.14 | Patch available | GHSA-c49r-8gj6-768r |
| — | symfony/symfony (Packagist) | 3.3.0 to before 3.3.13 | 3.3.13 | Patch available | GHSA-c49r-8gj6-768r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- symfony/intl (Packagist) Vendor— Affected 2.7.0 to before 2.7.38 Fixed in 2.7.38 Patch available GHSA-c49r-8gj6-768r
- symfony/intl (Packagist) Vendor— Affected 2.8.0 to before 2.8.31 Fixed in 2.8.31 Patch available GHSA-c49r-8gj6-768r
- symfony/intl (Packagist) Vendor— Affected 3.0.0 to before 3.2.14 Fixed in 3.2.14 Patch available GHSA-c49r-8gj6-768r
- symfony/intl (Packagist) Vendor— Affected 3.3.0 to before 3.3.13 Fixed in 3.3.13 Patch available GHSA-c49r-8gj6-768r
- symfony/symfony (Packagist) Vendor— Affected 2.7.0 to before 2.7.38 Fixed in 2.7.38 Patch available GHSA-c49r-8gj6-768r
- symfony/symfony (Packagist) Vendor— Affected 2.8.0 to before 2.8.31 Fixed in 2.8.31 Patch available GHSA-c49r-8gj6-768r
- symfony/symfony (Packagist) Vendor— Affected 3.0.0 to before 3.2.14 Fixed in 3.2.14 Patch available GHSA-c49r-8gj6-768r
- symfony/symfony (Packagist) Vendor— Affected 3.3.0 to before 3.3.13 Fixed in 3.3.13 Patch available GHSA-c49r-8gj6-768r
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 2.7.0 – 2.7.37; 3.2.0 – 3.2.13; 3.3.0 – 3.3.12; 3.8.0 – 3.8.30 | Vulnerable | sensiolabs |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.7.0 – 2.7.37; 3.2.0 – 3.2.13; 3.3.0 – 3.3.12; 3.8.0 – 3.8.30 Vulnerable ·sensiolabs
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-c49r-8gj6-768r symfony/intl (Packagist) Fixed in 2.7.38 Advisory →
- Fix · GHSA-c49r-8gj6-768r symfony/intl (Packagist) Fixed in 2.8.31 Advisory →
- Fix · GHSA-c49r-8gj6-768r symfony/intl (Packagist) Fixed in 3.2.14 Advisory →
- Fix · GHSA-c49r-8gj6-768r symfony/intl (Packagist) Fixed in 3.3.13 Advisory →
- Fix · GHSA-c49r-8gj6-768r symfony/symfony (Packagist) Fixed in 2.7.38 Advisory →
- Fix · GHSA-c49r-8gj6-768r symfony/symfony (Packagist) Fixed in 2.8.31 Advisory →
- Fix · GHSA-c49r-8gj6-768r symfony/symfony (Packagist) Fixed in 3.2.14 Advisory →
- Fix · GHSA-c49r-8gj6-768r symfony/symfony (Packagist) Fixed in 3.3.13 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16654
- 2026-10-03 Alias added: GHSA-c49r-8gj6-768r
References
Advisory 5
Sources
- CVE-2017-16654 · CVE Program
- CVE-2017-16654 · NVD
- FIRST EPSS
- GHSA-c49r-8gj6-768r · GitHub Advisory Database · CC BY 4.0
- CVE-2017-16654 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences