OpenCV 3.3.1 has a Buffer Overflow in the cv::PxMDecoder::readData function in…
Priority LOW 33CWE-119Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-119 and the CVSS impact.
Summary
OpenCV 3.3.1 has a Buffer Overflow in the cv::PxMDecoder::readData function in grfmt_pxm.cpp, because an incorrect size value is used.
Why it matters now
EPSS 0.0225 83rd percentileScored 2026-11-07
Fix Fixed opencv-python (PyPI): 3.4.0.12opencv-contrib-python (PyPI): 3.4.0.12
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | opencv-python (PyPI) | before 3.4.0.12 | 3.4.0.12 | Patch available | GHSA-jcxv-2j3h-mg59 |
| — | opencv-contrib-python (PyPI) | before 3.4.0.12 | 3.4.0.12 | Patch available | GHSA-jcxv-2j3h-mg59 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- opencv-python (PyPI) Vendor— Affected before 3.4.0.12 Fixed in 3.4.0.12 Patch available GHSA-jcxv-2j3h-mg59
- opencv-contrib-python (PyPI) Vendor— Affected before 3.4.0.12 Fixed in 3.4.0.12 Patch available GHSA-jcxv-2j3h-mg59
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opencv:opencv:3.3.1:*:*:*:*:*:*:* | 3.3.1 | Vulnerable | OpenCV |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:opencv:opencv:3.3.1:*:*:*:*:*:*:* Versions 3.3.1 Vulnerable ·OpenCV
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-jcxv-2j3h-mg59 opencv-python (PyPI) Fixed in 3.4.0.12 Advisory →
- Fix · GHSA-jcxv-2j3h-mg59 opencv-contrib-python (PyPI) Fixed in 3.4.0.12 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2017-17760
- 2026-10-03 Alias added: GHSA-jcxv-2j3h-mg59
References
Advisory 5
- [debian-lts-announce] 20180722 [SECURITY] [DLA 1438-1] opencv security update
- [debian-lts-announce] 20180108 [SECURITY] [DLA 1235-1] opencv security update
- https://github.com/opencv/opencv/issues/10351
- [debian-lts-announce] 20211030 [SECURITY] [DLA 2799-1] opencv security update
- https://nvd.nist.gov/vuln/detail/CVE-2017-17760
Sources
- CVE-2017-17760 · CVE Program
- CVE-2017-17760 · NVD
- FIRST EPSS
- GHSA-jcxv-2j3h-mg59 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-17760 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences