The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.
Why it matters now
EPSS 0.01194 68th percentileScored 2026-11-07
Fix Fixed simplesamlphp/simplesamlphp (Packagist): 1.14.16
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp (Packagist) | 1.12.0 to before 1.14.16 | 1.14.16 | Patch available | GHSA-fv7m-wc3v-wr3w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected 1.12.0 to before 1.14.16 Fixed in 1.14.16 Patch available GHSA-fv7m-wc3v-wr3w
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | up to 1.14.15 | Vulnerable | simplesamlphp |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions up to 1.14.15 Vulnerable ·simplesamlphp
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-fv7m-wc3v-wr3w simplesamlphp/simplesamlphp (Packagist) Fixed in 1.14.16 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-18121
- 2026-10-03 Alias added: GHSA-fv7m-wc3v-wr3w
References
Advisory 4
Sources
- CVE-2017-18121 · CVE Program
- CVE-2017-18121 · NVD
- FIRST EPSS
- GHSA-fv7m-wc3v-wr3w · GitHub Advisory Database · CC BY 4.0
- CVE-2017-18121 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences