A signature-validation bypass issue was discovered in SimpleSAMLphp through 1.14.16.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
A signature-validation bypass issue was discovered in SimpleSAMLphp through 1.14.16. A SimpleSAMLphp Service Provider using SAML 1.1 will regard as valid any unsigned SAML response containing more than one signed assertion, provided that the signature of at least one of the assertions is valid. Attributes contained in all the assertions received will be merged and the entityID of the first assertion received will be used, allowing an attacker to impersonate any user of any IdP given an assertion signed by the targeted IdP.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/simplesamlphp (Packagist) | before 1.14.17 | 1.14.17 | Patch available | GHSA-j4qf-3w33-8cgc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/simplesamlphp (Packagist) Vendor— Affected before 1.14.17 Fixed in 1.14.17 Patch available GHSA-j4qf-3w33-8cgc
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | up to 1.14.16 | Vulnerable | simplesamlphp |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions up to 1.14.16 Vulnerable ·simplesamlphp
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-j4qf-3w33-8cgc simplesamlphp/simplesamlphp (Packagist) Fixed in 1.14.17 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-18122
- 2026-10-03 Alias added: GHSA-j4qf-3w33-8cgc
References
Advisory 3
Sources
- CVE-2017-18122 · CVE Program
- CVE-2017-18122 · NVD
- FIRST EPSS
- GHSA-j4qf-3w33-8cgc · GitHub Advisory Database · CC BY 4.0
- CVE-2017-18122 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences