The note-press plugin before 0.1.2 for WordPress has SQL injection.
Priority MEDIUM 46CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The note-press plugin before 0.1.2 for WordPress has SQL injection.
Why it matters now
EPSS 0.01813 78th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:datainterlock:note_press:*:*:*:*:*:wordpress:*:* | before 0.1.2 | Vulnerable | Datainterlock |
- cpe:2.3:a:datainterlock:note_press:*:*:*:*:*:wordpress:*:* Versions before 0.1.2 Vulnerable ·Datainterlock
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2017-18548
- 2026-10-03 Alias added: GHSA-x8jx-g9qm-xr7m
References
More Datainterlock Note Press vulnerabilities
- TI-2022-01558 Note Press <= 0.1.10 - Admin+ SQLi via Bulk Actions CVSS 3.1LOW 2.7
- TI-2022-01557 Note Press <= 0.1.10 - Admin+ SQLi via Update CVSS 3.1LOW 2.7
- TI-2022-01556 Note Press <= 0.1.10 - Admin+ SQLi via id CVSS 3.1LOW 2.7
Sources
- CVE-2017-18548 · CVE Program
- CVE-2017-18548 · NVD
- FIRST EPSS
- GHSA-x8jx-g9qm-xr7m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences