Read the docs
TI-2017-13790 Aliases CVE-2017-18635GHSA-49rv-g7w5-m8xx

An XSS vulnerability was discovered in noVNC before 0.6.2 in which the remote VNC server…

Priority LOW 35CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 3 fixed, 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

An XSS vulnerability was discovered in noVNC before 0.6.2 in which the remote VNC server could inject arbitrary HTML into the noVNC web page via the messages propagated to the status field, such as the VNC server name.

Why it matters now

EPSS 0.04788 91st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial @novnc/novnc (npm): 0.6.2Red Hat: 2 advisoriesRed Hat: 3 fixed, 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—@novnc/novnc (npm)before 0.6.20.6.2Patch availableGHSA-49rv-g7w5-m8xx
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • @novnc/novnc (npm) Vendor— Affected before 0.6.2 Fixed in 0.6.2 Patch available GHSA-49rv-g7w5-m8xx

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:novnc:novnc:*:*:*:*:*:*:*:*before 0.6.2VulnerableNovnc
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:*16.04VulnerableCanonical
cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:*13VulnerableRed Hat
  • cpe:2.3:a:novnc:novnc:*:*:*:*:*:*:*:* Versions before 0.6.2 Vulnerable ·Novnc
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* Versions 16.04 Vulnerable ·Canonical
  • cpe:2.3:a:redhat:openstack:13:*:*:*:*:*:*:* Versions 13 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-49rv-g7w5-m8xx @novnc/novnc (npm) Fixed in 0.6.2 Advisory →

Red Hat 2 advisories

  • RHSA-2020:3247 Released 2020-08-04 · Red Hat rating Important
    RHV Manager (ovirt-engine) 4.4 security, bug fix, and enhancement update
    • RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4 novnc-1.1.0-1.el8ost, ovirt-engine-4.4.1.8-0.7.el8ev, ovirt-engine-api-explorer-0.0.6-1.el8ev +21
  • RHSA-2020:0754 Released 2020-03-10 · Red Hat rating Moderate
    novnc security update
    • Red Hat OpenStack Platform 13.0 novnc-1.1.0-2.el7ost
    • Red Hat OpenStack Platform 13.0 for RHEL 7.6 EUS Server novnc-1.1.0-2.el7ost

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenStack Platform 10 (Newton)AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 14 (Rocky)AffectedNo fix yet: Fix deferred
RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4Fixed RHSA-2020:3247
Red Hat OpenStack Platform 13.0Fixed RHSA-2020:0754
Red Hat OpenStack Platform 13.0 for RHEL 7.6 EUS ServerFixed RHSA-2020:0754
Not affected: 2 products
  • RHEL-8-RHEV-S-4.4 - Red Hat Virtualization Engine 4.4
  • Red Hat OpenStack Platform 15 (Stein)

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-18635
  2. 2026-10-03 Alias added: GHSA-49rv-g7w5-m8xx

References

Sources