HumHub DOM cross site scriting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-80.
Summary
A vulnerability was found in HumHub up to 1.0.1 and classified as problematic. Affected by this issue is some unknown functionality. The manipulation leads to cross site scripting (DOM). The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.1 is able to address this issue. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| unspecified | HumHub | 1.0.0; 1.0.1 | — | No fix listed | CNA |
- HumHub Vendorunspecified Affected 1.0.0; 1.0.1 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2017-20027
- 2026-10-03 Alias added: GHSA-7pxw-jp74-vp3g
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
More Humhub vulnerabilities
- TI-2022-08676 Improper access control in humhub CVSS 3.1MEDIUM 6.5
- TI-2017-14097 HumHub Reflected cross site scriting CVSS 3.1MEDIUM 6.1
- TI-2017-14099 HumHub privileges management CVSS 3.1CRITICAL 9.8
- TI-2024-34921 User enumeration in HubHub CVSS 4.0MEDIUM 6.9
- TI-2014-07750 SQL injection vulnerability in the actionIndex function in… CVSS 2.0HIGH 7.5
- TI-2019-08643 A cross-site scripting (XSS) vulnerability in HumHub 1.3.12 allows remote attackers to… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2017-20027 · CVE Program
- CVE-2017-20027 · NVD
- FIRST EPSS
- GHSA-7pxw-jp74-vp3g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences