Elefant CMS Version Comparison Persistent cross site scriting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-80.
Summary
A vulnerability classified as problematic was found in Elefant CMS 1.3.12-RC. Affected by this vulnerability is an unknown functionality of the component Version Comparison. The manipulation leads to basic cross site scripting (Persistent). The attack can be launched remotely. Upgrading to version 1.3.13 is able to address this issue. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elefant | CMS | 1.3.12-RC | — | No fix listed | CNA |
| — | elefant/cms (Packagist) | before 1.3.13 | 1.3.13 | Patch available | GHSA-5hfm-g799-wjw6 |
- CMS VendorElefant Affected 1.3.12-RC Fixed in — No fix listed CNA
- elefant/cms (Packagist) Vendor— Affected before 1.3.13 Fixed in 1.3.13 Patch available GHSA-5hfm-g799-wjw6
Remediation
- Fix · GHSA-5hfm-g799-wjw6 elefant/cms (Packagist) Fixed in 1.3.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-20058
- 2026-10-03 Alias added: GHSA-5hfm-g799-wjw6
References
More Elefantcms vulnerabilities
- TI-2018-11128 apps/filemanager/handlers/upload/drop.php in Elefant CMS 2.0.3 performs a urldecode step… CVSS 3.0CRITICAL 9.8
- TI-2018-11745 An issue was discovered in Elefant CMS before 2.0.5. CVSS 3.0HIGH 8.8
- TI-2012-01168 Multiple cross-site scripting (XSS) vulnerabilities in apps/admin/handlers/preview.php in… CVSS 2.0MEDIUM 4.3
- TI-2012-05239 Cross-site scripting (XSS) vulnerability in apps/admin/handlers/versions.php in Elefant… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2017-20058 · CVE Program
- CVE-2017-20058 · NVD
- FIRST EPSS
- GHSA-5hfm-g799-wjw6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences