Ariadne Component Library Url.php server-side request forgery
Priority MEDIUM 43CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
A vulnerability was found in Ariadne Component Library up to 2.x. It has been classified as critical. Affected is an unknown function of the file src/url/Url.php. The manipulation leads to server-side request forgery. Upgrading to version 3.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217140.
Why it matters now
EPSS 0.00725 54th percentileScored 2026-11-07
Fix Fixed arc/web (Packagist): 3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Ariadne | Component Library | 2.x | — | No fix listed | CNA |
| — | arc/web (Packagist) | before 3.0 | 3.0 | Patch available | GHSA-qr97-v87p-x965 |
- Component Library VendorAriadne Affected 2.x Fixed in — No fix listed CNA
- arc/web (Packagist) Vendor— Affected before 3.0 Fixed in 3.0 Patch available GHSA-qr97-v87p-x965
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ariadne-cms:ariadne_component_library:*:*:*:*:*:*:*:* | before 3.0 | Vulnerable | Ariadne-cms |
- cpe:2.3:a:ariadne-cms:ariadne_component_library:*:*:*:*:*:*:*:* Versions before 3.0 Vulnerable ·Ariadne-cms
Remediation
- Fix · GHSA-qr97-v87p-x965 arc/web (Packagist) Fixed in 3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-20157
- 2026-10-03 Alias added: GHSA-qr97-v87p-x965
References
More Ariadne vulnerabilities
- TI-2005-01119 NOTE: this issue has been disputed by the vendor. CVSS 2.0HIGH 7.5
- TI-2006-05560 Multiple PHP remote file inclusions in Ariadne 2.4.1 allows remote attackers to execute… CVSS 2.0HIGH 7.5
- TI-2007-02350 Cross-site scripting (XSS) vulnerability in index.php in Ariadne 2.4.1 allows remote… CVSS 2.0MEDIUM 6.8
- TI-2011-04248 Cross-site scripting in Ariadne CVSS 3.1MEDIUM 6.1
Sources
- CVE-2017-20157 · CVE Program
- CVE-2017-20157 · NVD
- FIRST EPSS
- GHSA-qr97-v87p-x965 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences