vova07 Yii2 FileAPI Widget UploadAction.php run cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 is able to address this issue. The identifier of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vova07 | Yii2 FileAPI Widget | 0.1.0; 0.1.1; 0.1.2; 0.1.3; 0.1.4; 0.1.5; 0.1.6; 0.1.7; 0.1.8 | — | No fix listed | CNA |
| — | vova07/yii2-fileapi-widget (Packagist) | before 0.1.9 | 0.1.9 | Patch available | GHSA-j82x-fh8h-326g |
- Yii2 FileAPI Widget Vendorvova07 Affected 0.1.0; 0.1.1; 0.1.2; 0.1.3; 0.1.4; 0.1.5; 0.1.6; 0.1.7; 0.1.8 Fixed in — No fix listed CNA
- vova07/yii2-fileapi-widget (Packagist) Vendor— Affected before 0.1.9 Fixed in 0.1.9 Patch available GHSA-j82x-fh8h-326g
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:yii2_fileapi_widget_project:yii2_fileapi_widget:*:*:*:*:*:*:*:* | before 0.1.9 | Vulnerable | Yii2 Fileapi Widget Project |
- cpe:2.3:a:yii2_fileapi_widget_project:yii2_fileapi_widget:*:*:*:*:*:*:*:* Versions before 0.1.9 Vulnerable ·Yii2 Fileapi Widget Project
Remediation
- Fix · GHSA-j82x-fh8h-326g vova07/yii2-fileapi-widget (Packagist) Fixed in 0.1.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-20158
- 2026-10-03 Alias added: GHSA-j82x-fh8h-326g
References
Sources
- CVE-2017-20158 · CVE Program
- CVE-2017-20158 · NVD
- FIRST EPSS
- GHSA-j82x-fh8h-326g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences