rf Keynote rumble.rb cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability was found in rf Keynote up to 0.x on Rails. It has been rated as problematic. Affected by this issue is some unknown functionality of the file lib/keynote/rumble.rb. The manipulation of the argument value leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as 05be4356b0a6ca7de48da926a9b997beb5ffeb4a. It is recommended to upgrade the affected component. VDB-217142 is the identifier assigned to this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| rf | Keynote | 0.x | — | No fix listed | CNA |
| — | keynote (RubyGems) | before 1.0.0 | 1.0.0 | Patch available | GHSA-399p-vq28-5hg8 |
- Keynote Vendorrf Affected 0.x Fixed in — No fix listed CNA
- keynote (RubyGems) Vendor— Affected before 1.0.0 Fixed in 1.0.0 Patch available GHSA-399p-vq28-5hg8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:keynote_project:keynote:*:*:*:*:*:ruby:*:* | before 1.0.0 | Vulnerable | Keynote Project |
- cpe:2.3:a:keynote_project:keynote:*:*:*:*:*:ruby:*:* Versions before 1.0.0 Vulnerable ·Keynote Project
Remediation
- Fix · GHSA-399p-vq28-5hg8 keynote (RubyGems) Fixed in 1.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-20159
- 2026-10-03 Alias added: GHSA-399p-vq28-5hg8
References
Patch 2
Sources
- CVE-2017-20159 · CVE Program
- CVE-2017-20159 · NVD
- FIRST EPSS
- GHSA-399p-vq28-5hg8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences