Read the docs
TI-2017-14231 Aliases CVE-2017-20165GHSA-9vvw-cc9w-f27h

debug-js debug node.js useColors redos

Priority LOW 37CWE-1333Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1333.

Summary

A vulnerability classified as problematic has been found in debug-js debug up to 3.0.x. This affects the function useColors of the file src/node.js. The manipulation of the argument str leads to inefficient regular expression complexity. Upgrading to version 3.1.0 is able to address this issue. The identifier of the patch is c38a0166c266a679c8de012d4eaccec3f944e685. It is recommended to upgrade the affected component. The identifier VDB-217665 was assigned to this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02105 81st percentileScored 2026-11-07
Fix Fixed debug (npm): 3.1.0, 2.6.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
debug-jsdebug3.0—No fix listedCNA
—debug (npm)3.0.0 to before 3.1.03.1.0Patch availableGHSA-9vvw-cc9w-f27h
—debug (npm)before 2.6.92.6.9Patch availableGHSA-9vvw-cc9w-f27h
  • debug Vendordebug-js Affected 3.0 Fixed in — No fix listed CNA
  • debug (npm) Vendor— Affected 3.0.0 to before 3.1.0 Fixed in 3.1.0 Patch available GHSA-9vvw-cc9w-f27h
  • debug (npm) Vendor— Affected before 2.6.9 Fixed in 2.6.9 Patch available GHSA-9vvw-cc9w-f27h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:debug_project:debug:*:*:*:*:*:node.js:*:*before 2.6.9; 3.0.0 to before 3.1.0VulnerableDebug Project
  • cpe:2.3:a:debug_project:debug:*:*:*:*:*:node.js:*:* Versions before 2.6.9; 3.0.0 to before 3.1.0 Vulnerable ·Debug Project

Remediation

  • Fix · GHSA-9vvw-cc9w-f27h debug (npm) Fixed in 3.1.0 Advisory →
  • Fix · GHSA-9vvw-cc9w-f27h debug (npm) Fixed in 2.6.9 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-20165
  2. 2026-10-03 Alias added: GHSA-9vvw-cc9w-f27h

References

Sources