Read the docs
TI-2017-14241 Aliases CVE-2017-20175GHSA-hc67-v29c-7g78

DaSchTour matomo-mediawiki-extension Username Piwik.hooks.php cross site scripting

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A vulnerability classified as problematic has been found in DaSchTour matomo-mediawiki-extension up to 2.4.2 on MediaWiki. This affects an unknown part of the file Piwik.hooks.php of the component Username Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.4.3 is able to address this issue. The patch is named 681324e4f518a8af4bd1f93867074c728eb9923d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220203.

Why it matters now

EPSS 0.00614 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed mediawiki/matomo (Packagist): 2.4.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
DaSchTourmatomo-mediawiki-extension2.4.0; 2.4.1; 2.4.2—No fix listedCNA
—mediawiki/matomo (Packagist)before 2.4.32.4.3Patch availableGHSA-hc67-v29c-7g78
  • matomo-mediawiki-extension VendorDaSchTour Affected 2.4.0; 2.4.1; 2.4.2 Fixed in — No fix listed CNA
  • mediawiki/matomo (Packagist) Vendor— Affected before 2.4.3 Fixed in 2.4.3 Patch available GHSA-hc67-v29c-7g78

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mediawiki:matomo:*:*:*:*:*:mediawiki:*:*2.4.0 to before 2.4.3Vulnerablemediawiki
  • cpe:2.3:a:mediawiki:matomo:*:*:*:*:*:mediawiki:*:* Versions 2.4.0 to before 2.4.3 Vulnerable ·mediawiki

Remediation

  • Fix · GHSA-hc67-v29c-7g78 mediawiki/matomo (Packagist) Fixed in 2.4.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-20175
  2. 2026-10-03 Alias added: GHSA-hc67-v29c-7g78

References

Sources