Read the docs
TI-2017-14244 Aliases CVE-2017-20178GHSA-2q79-56rq-8v3c

Codiad process.php saveJSON information disclosure

Priority LOW 34CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in Codiad 2.8.0. It has been rated as problematic. Affected by this issue is the function saveJSON of the file components/install/process.php. The manipulation of the argument data leads to information disclosure. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 2.8.1 is able to address this issue. The patch is identified as 517119de673e62547ee472a730be0604f44342b5. It is recommended to upgrade the affected component. VDB-221498 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Why it matters now

EPSS 0.00682 52nd percentileScored 2026-11-07
Fix Fixed codiad/codiad (Packagist): 2.8.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Codiad2.8.0—No fix listedCNA
—codiad/codiad (Packagist)before 2.8.12.8.1Patch availableGHSA-2q79-56rq-8v3c
  • Codiad Vendor— Affected 2.8.0 Fixed in — No fix listed CNA
  • codiad/codiad (Packagist) Vendor— Affected before 2.8.1 Fixed in 2.8.1 Patch available GHSA-2q79-56rq-8v3c

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:codiad:codiad:2.8.0:*:*:*:*:*:*:*2.8.0VulnerableCodiad
  • cpe:2.3:a:codiad:codiad:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Codiad

Remediation

  • Fix · GHSA-2q79-56rq-8v3c codiad/codiad (Packagist) Fixed in 2.8.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-20178
  2. 2026-10-03 Alias added: GHSA-2q79-56rq-8v3c

References

  • TI-2018-10126 Codiad through 2.8.4 allows Remote Code Execution, a different vulnerability than CVE-2017-11366 and CVE-2017-15689. CVSS 3.1CRITICAL 9.8
  • TI-2019-13840 Codiad Web IDE through 2.8.4 allows PHP Code injection. CVSS 3.1CRITICAL 9.8
  • TI-2017-08403 components/filemanager/class.filemanager.php in Codiad before 2.8.4 is vulnerable to… CVSS 3.0CRITICAL 9.8
  • TI-2018-13754 Codiad 2.8.4 allows remote authenticated administrators to execute arbitrary code by uploading an executable file. CVSS 3.1HIGH 7.2
  • TI-2020-11002 ** PRODUCT NOT SUPPORTED WHEN ASSIGNED ** A Cross Side Request Forgery (CSRF)… CVSS 3.1HIGH 8.8
  • TI-2020-11003 ** PRODUCT NOT SUPPORTED WHEN ASSIGNED ** A Server-Side Request Forgery (SSRF)… CVSS 3.1HIGH 7.2
See all 13 →

Sources