Mobile Vikings Django AJAX Utilities Backslash pagination.js Pagination cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability was found in Mobile Vikings Django AJAX Utilities up to 1.2.1 and classified as problematic. This issue affects the function Pagination of the file django_ajax/static/ajax-utilities/js/pagination.js of the component Backslash Handler. The manipulation of the argument url leads to cross site scripting. The attack may be initiated remotely. The patch is named 329eb1dd1580ca1f9d4f95bc69939833226515c9. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-222611.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mobile Vikings | Django AJAX Utilities | 1.2.0; 1.2.1 | — | No fix listed | CNA |
| — | django-ajax-utilities (PyPI) | before 1.2.8 | 1.2.8 | Patch available | GHSA-p4g9-c9qr-wmg5 |
- Django AJAX Utilities VendorMobile Vikings Affected 1.2.0; 1.2.1 Fixed in — No fix listed CNA
- django-ajax-utilities (PyPI) Vendor— Affected before 1.2.8 Fixed in 1.2.8 Patch available GHSA-p4g9-c9qr-wmg5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mobilevikings:django_ajax_utilities:*:*:*:*:*:*:*:* | up to 1.2.1 | Vulnerable | Mobile Vikings |
- cpe:2.3:a:mobilevikings:django_ajax_utilities:*:*:*:*:*:*:*:* Versions up to 1.2.1 Vulnerable ·Mobile Vikings
Remediation
- Fix · GHSA-p4g9-c9qr-wmg5 django-ajax-utilities (PyPI) Fixed in 1.2.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-20182
- 2026-10-03 Alias added: GHSA-p4g9-c9qr-wmg5
References
Patch 1
Sources
- CVE-2017-20182 · CVE Program
- CVE-2017-20182 · NVD
- FIRST EPSS
- GHSA-p4g9-c9qr-wmg5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences