Read the docs
TI-2017-14255 Aliases CVE-2017-20189GHSA-jgxc-8mwq-9xqw

In Clojure before 1.9.0, classes can be used to construct a serialized object that…

Priority HIGH 82CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

In Clojure before 1.9.0, classes can be used to construct a serialized object that executes arbitrary code upon deserialization. This is relevant if a server deserializes untrusted objects.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01332 71st percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed org.clojure:clojure (Maven): 1.9.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.clojure:clojure (Maven)before 1.9.01.9.0Patch availableGHSA-jgxc-8mwq-9xqw
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.clojure:clojure (Maven) Vendor— Affected before 1.9.0 Fixed in 1.9.0 Patch available GHSA-jgxc-8mwq-9xqw

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:clojure:clojure:*:*:*:*:*:*:*:*before 1.9.0VulnerableClojure
  • cpe:2.3:a:clojure:clojure:*:*:*:*:*:*:*:* Versions before 1.9.0 Vulnerable ·Clojure

Remediation

  • Fix · GHSA-jgxc-8mwq-9xqw org.clojure:clojure (Maven) Fixed in 1.9.0 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-20189
  2. 2026-10-03 Alias added: GHSA-jgxc-8mwq-9xqw

References

  • TI-2024-15159 An issue in Clojure versions 1.20 to 1.12.0-alpha5 allows an attacker to cause a denial… CVSS 3.1HIGH 7.5

Sources