Flickr Gallery <= 1.5.2 - Unauthenticated PHP Object Injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
The Flickr Gallery plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 1.5.2 via deserialization of untrusted input from the `pager ` parameter. This allows unauthenticated attackers to inject a PHP Object. Attackers were actively exploiting this vulnerability with the WP_Theme() class to create backdoors.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dan Coulter | Flickr Gallery | before 1.5.3 | 1.5.3 | Patch available | CNA |
- Flickr Gallery VendorDan Coulter Affected before 1.5.3 Fixed in 1.5.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dancoulter:flickr_gallery:*:*:*:*:*:wordpress:*:* | up to 1.5.2 | Vulnerable | Dan Coulter |
- cpe:2.3:a:dancoulter:flickr_gallery:*:*:*:*:*:wordpress:*:* Versions up to 1.5.2 Vulnerable ·Dan Coulter
Remediation
- Fix · CNA Flickr Gallery (Dan Coulter) Fixed in 1.5.3
Timeline
- 2026-10-02 Threatist record created from CVE-2017-20207
- 2026-10-03 Alias added: GHSA-vv63-gqpw-3x4p
References
Sources
- CVE-2017-20207 · CVE Program
- CVE-2017-20207 · NVD
- FIRST EPSS
- GHSA-vv63-gqpw-3x4p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences