WordPress Insert PHP Plugin < 3.3.1 PHP Code Injection via REST API
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-94.
Summary
WordPress Insert PHP plugin versions before 3.3.1 contain a PHP code injection vulnerability that allows unauthenticated attackers to execute arbitrary PHP code by injecting malicious shortcodes through the WordPress REST API. Attackers can send POST requests to the wp-json/wp/v2/posts endpoint with crafted content containing insert_php shortcodes to include and execute remote PHP files on the server.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Woody Code Snippets (Themeisle) Fixed in 3.3.1
Timeline
- 2026-10-02 Threatist record created from CVE-2017-20251
- 2026-10-03 Alias added: GHSA-mxq7-4xcj-jccm
- 2026-10-29 Title updated · CNA
References
Exploit 1
Other 1
More themeisle vulnerabilities
- TI-2023-02146 Otter - Gutenberg Blocks < 2.2.6 - Author+ PHAR Deserialization CVSS 3.1HIGH 8.8
- TI-2023-20819 WordPress Redirection for Contact Form 7 plugin <= 2.9.2 - Broken Access Control vulnerability CVSS 3.1HIGH 7.5
- TI-2019-12631 A blind SSRF vulnerability exists in the Visualizer plugin before 3.3.1 for WordPress via… CVSS 3.1CRITICAL 10.0
- TI-2023-02115 Product Addons & Fields for WooCommerce < 32.0.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-04265 RSS Aggregator by Feedzy < 4.1.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-01727 Product Addons & Fields for WooCommerce < 32.0.6 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2017-20251 · CVE Program
- CVE-2017-20251 · NVD
- FIRST EPSS
- GHSA-mxq7-4xcj-jccm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences