Read the docs

FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message…

Priority LOW 36CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

FedMsg 0.18.1 and older is vulnerable to a message validation flaw resulting in message validation not being enabled if configured to be on.

Why it matters now

EPSS 0.01505 74th percentileScored 2026-11-07
Fix Fixed FedMsg (PyPI): 0.18.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—FedMsg (PyPI)before 0.18.20.18.2Patch availableGHSA-p7xc-35m8-57pr
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • FedMsg (PyPI) Vendor— Affected before 0.18.2 Fixed in 0.18.2 Patch available GHSA-p7xc-35m8-57pr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:fedoraproject:fedmsg:*:*:*:*:*:*:*:*up to 0.18.1VulnerableFedoraproject
  • cpe:2.3:a:fedoraproject:fedmsg:*:*:*:*:*:*:*:* Versions up to 0.18.1 Vulnerable ·Fedoraproject

Remediation

  • Fix · GHSA-p7xc-35m8-57pr FedMsg (PyPI) Fixed in 0.18.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000001
  2. 2026-10-03 Alias added: GHSA-p7xc-35m8-57pr

References

Sources