Read the docs

Mapbox.js versions 1.x prior to 1.6.6 and 2.x prior to 2.2.4 are vulnerable to a…

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Mapbox.js versions 1.x prior to 1.6.6 and 2.x prior to 2.2.4 are vulnerable to a cross-site-scripting attack in certain uncommon usage scenarios via TileJSON name and map share control

Why it matters now

EPSS 0.00935 61st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mapbox.js (npm): 1.6.6, 2.2.4mapbox-rails (RubyGems): 1.6.6, 2.2.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mapbox.js (npm)before 1.6.61.6.6Patch availableGHSA-q69p-5h74-w36f
—mapbox.js (npm)2.0.0 to before 2.2.42.2.4Patch availableGHSA-q69p-5h74-w36f
—mapbox-rails (RubyGems)1.0.0 to before 1.6.61.6.6Patch availableGHSA-q69p-5h74-w36f
—mapbox-rails (RubyGems)2.0.0 to before 2.2.42.2.4Patch availableGHSA-q69p-5h74-w36f
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mapbox.js (npm) Vendor— Affected before 1.6.6 Fixed in 1.6.6 Patch available GHSA-q69p-5h74-w36f
  • mapbox.js (npm) Vendor— Affected 2.0.0 to before 2.2.4 Fixed in 2.2.4 Patch available GHSA-q69p-5h74-w36f
  • mapbox-rails (RubyGems) Vendor— Affected 1.0.0 to before 1.6.6 Fixed in 1.6.6 Patch available GHSA-q69p-5h74-w36f
  • mapbox-rails (RubyGems) Vendor— Affected 2.0.0 to before 2.2.4 Fixed in 2.2.4 Patch available GHSA-q69p-5h74-w36f

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mapbox:mapbox.js:*:*:*:*:*:node.js:*:*1.0.0 to before 1.6.6; 2.0.0 to before 2.2.4VulnerableMapbox
  • cpe:2.3:a:mapbox:mapbox.js:*:*:*:*:*:node.js:*:* Versions 1.0.0 to before 1.6.6; 2.0.0 to before 2.2.4 Vulnerable ·Mapbox

Remediation

  • Fix · GHSA-q69p-5h74-w36f mapbox.js (npm) Fixed in 1.6.6 Advisory →
  • Fix · GHSA-q69p-5h74-w36f mapbox.js (npm) Fixed in 2.2.4 Advisory →
  • Fix · GHSA-q69p-5h74-w36f mapbox-rails (RubyGems) Fixed in 1.6.6 Advisory →
  • Fix · GHSA-q69p-5h74-w36f mapbox-rails (RubyGems) Fixed in 2.2.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000043
  2. 2026-10-03 Alias added: GHSA-q69p-5h74-w36f

References

Sources