Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to null byte injection…
Priority LOW 34CWE-74Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to null byte injection in the Plug.Static component, which may allow users to bypass filetype restrictions.
Why it matters now
EPSS 0.00423 36th percentileScored 2026-11-07
Fix Fixed plug (Hex): 1.0.4, 1.1.7, 1.2.3 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | plug (Hex) | before 1.0.4 | 1.0.4 | Patch available | GHSA-2q6v-32mr-8p8x |
| — | plug (Hex) | 1.1.0 to before 1.1.7 | 1.1.7 | Patch available | GHSA-2q6v-32mr-8p8x |
| — | plug (Hex) | 1.2.0 to before 1.2.3 | 1.2.3 | Patch available | GHSA-2q6v-32mr-8p8x |
| — | plug (Hex) | 1.3.0 to before 1.3.2 | 1.3.2 | Patch available | GHSA-2q6v-32mr-8p8x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- plug (Hex) Vendor— Affected before 1.0.4 Fixed in 1.0.4 Patch available GHSA-2q6v-32mr-8p8x
- plug (Hex) Vendor— Affected 1.1.0 to before 1.1.7 Fixed in 1.1.7 Patch available GHSA-2q6v-32mr-8p8x
- plug (Hex) Vendor— Affected 1.2.0 to before 1.2.3 Fixed in 1.2.3 Patch available GHSA-2q6v-32mr-8p8x
- plug (Hex) Vendor— Affected 1.3.0 to before 1.3.2 Fixed in 1.3.2 Patch available GHSA-2q6v-32mr-8p8x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:plug_project:plug:*:*:*:*:*:*:*:* | 1.0.0 to before 1.0.4; 1.1.0 to before 1.1.7; 1.2.0 to before 1.2.3; 1.3.0 to before 1.3.2 | Vulnerable | Plug Project |
- cpe:2.3:a:plug_project:plug:*:*:*:*:*:*:*:* Versions 1.0.0 to before 1.0.4; 1.1.0 to before 1.1.7; 1.2.0 to before 1.2.3; 1.3.0 to before 1.3.2 Vulnerable ·Plug Project
Remediation
- Fix · GHSA-2q6v-32mr-8p8x plug (Hex) Fixed in 1.0.4 Advisory →
- Fix · GHSA-2q6v-32mr-8p8x plug (Hex) Fixed in 1.1.7 Advisory →
- Fix · GHSA-2q6v-32mr-8p8x plug (Hex) Fixed in 1.2.3 Advisory →
- Fix · GHSA-2q6v-32mr-8p8x plug (Hex) Fixed in 1.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000052
- 2026-10-03 Alias added: GHSA-2q6v-32mr-8p8x
References
More Plug Project Plug vulnerabilities
- TI-2017-14394 Elixir Plug before v1.0.4, v1.1.7, v1.2.3 and v1.3.2 is vulnerable to arbitrary code… CVSS 3.1HIGH 8.1
- TI-2018-16102 Elixir Plug Plug version All contains a Header Injection vulnerability in Connection that… CVSS 3.0MEDIUM 6.5
Sources
- CVE-2017-1000052 · CVE Program
- CVE-2017-1000052 · NVD
- FIRST EPSS
- GHSA-2q6v-32mr-8p8x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences