Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the…
Priority MEDIUM 47CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-862.
Summary
Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing PodSecurityPolicy object.
Why it matters now
EPSS 0.0284 86th percentileScored 2026-11-07
Fix Partial k8s.io/kubernetes (Go): 1.5.5Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | k8s.io/kubernetes (Go) | 1.5.0 to before 1.5.5 | 1.5.5 | Patch available | GHSA-2jx2-76rc-2v7v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- k8s.io/kubernetes (Go) Vendor— Affected 1.5.0 to before 1.5.5 Fixed in 1.5.5 Patch available GHSA-2jx2-76rc-2v7v
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kubernetes:kubernetes:1.5.0:*:*:*:*:*:*:* | 1.5.0 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.5.1:*:*:*:*:*:*:* | 1.5.1 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.5.2:*:*:*:*:*:*:* | 1.5.2 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.5.3:*:*:*:*:*:*:* | 1.5.3 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.5.4:*:*:*:*:*:*:* | 1.5.4 | Vulnerable | Kubernetes |
- cpe:2.3:a:kubernetes:kubernetes:1.5.0:*:*:*:*:*:*:* Versions 1.5.0 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.5.1:*:*:*:*:*:*:* Versions 1.5.1 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.5.2:*:*:*:*:*:*:* Versions 1.5.2 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.5.3:*:*:*:*:*:*:* Versions 1.5.3 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.5.4:*:*:*:*:*:*:* Versions 1.5.4 Vulnerable ·Kubernetes
Remediation
- Fix · GHSA-2jx2-76rc-2v7v k8s.io/kubernetes (Go) Fixed in 1.5.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
Not affected: 1 product
- Red Hat OpenShift Enterprise 3
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000056
- 2026-10-03 Alias added: GHSA-2jx2-76rc-2v7v
References
More Kubernetes vulnerabilities
- TI-2018-16130 Improper privilege management in Kubernetes CVSS 3.0CRITICAL 9.8
- TI-2019-08418 Kubernetes kubelet exposes /debug/pprof info on healthz port CVSS 3.1HIGH 8.2
- TI-2023-05086 Kubernetes - Windows nodes - Insufficient input sanitization in in-tree storage plugin leads to privilege escalation CVSS 3.1HIGH 8.8
- TI-2023-03433 Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation CVSS 3.1HIGH 8.8
- TI-2023-02285 Bypass of seccomp profile enforcement CVSS 3.1MEDIUM 5.5
- TI-2017-14755 Link following in Kubernetes CVSS 3.0CRITICAL 9.6
Sources
- CVE-2017-1000056 · CVE Program
- CVE-2017-1000056 · NVD
- FIRST EPSS
- GHSA-2jx2-76rc-2v7v · GitHub Advisory Database · CC BY 4.0
- CVE-2017-1000056 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences