The Periodic Backup Plugin did not perform any permission checks, allowing any user with…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
The Periodic Backup Plugin did not perform any permission checks, allowing any user with Overall/Read access to change its settings, trigger backups, restore backups, download backups, and also delete all previous backups via log rotation. Additionally, the plugin was not requiring requests to its API be sent via POST, thereby opening itself to Cross-Site Request Forgery attacks.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:periodicbackup (Maven) | before 1.5 | 1.5 | Patch available | GHSA-5293-3fgp-cr3x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:periodicbackup (Maven) Vendor— Affected before 1.5 Fixed in 1.5 Patch available GHSA-5293-3fgp-cr3x
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins:periodic_backup:1.0:*:*:*:*:jenkins:*:* | 1.0 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:periodic_backup:1.1:*:*:*:*:jenkins:*:* | 1.1 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:periodic_backup:1.2:*:*:*:*:jenkins:*:* | 1.2 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:periodic_backup:1.3:*:*:*:*:jenkins:*:* | 1.3 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:periodic_backup:1.4:*:*:*:*:jenkins:*:* | 1.4 | Vulnerable | Jenkins |
- cpe:2.3:a:jenkins:periodic_backup:1.0:*:*:*:*:jenkins:*:* Versions 1.0 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:periodic_backup:1.1:*:*:*:*:jenkins:*:* Versions 1.1 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:periodic_backup:1.2:*:*:*:*:jenkins:*:* Versions 1.2 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:periodic_backup:1.3:*:*:*:*:jenkins:*:* Versions 1.3 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:periodic_backup:1.4:*:*:*:*:jenkins:*:* Versions 1.4 Vulnerable ·Jenkins
Remediation
- Fix · GHSA-5293-3fgp-cr3x org.jenkins-ci.plugins:periodicbackup (Maven) Fixed in 1.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000086
- 2026-10-03 Alias added: GHSA-5293-3fgp-cr3x
References
Sources
- CVE-2017-1000086 · CVE Program
- CVE-2017-1000086 · NVD
- FIRST EPSS
- GHSA-5293-3fgp-cr3x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences