Read the docs

Poll SCM Plugin was not requiring requests to its API be sent via POST, thereby opening…

Priority LOW 39CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

Poll SCM Plugin was not requiring requests to its API be sent via POST, thereby opening itself to Cross-Site Request Forgery attacks. This allowed attackers to initiate polling of projects with a known name. While Jenkins in general does not consider polling to be a protection-worthy action as it's similar to cache invalidation, the plugin specifically adds a permission to be able to use this functionality, and this issue undermines that permission.

Why it matters now

EPSS 0.00678 52nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:pollscm (Maven): 1.3.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.plugins:pollscm (Maven)before 1.3.11.3.1Patch availableGHSA-fv3c-6cw7-2qcq
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:pollscm (Maven) Vendor— Affected before 1.3.1 Fixed in 1.3.1 Patch available GHSA-fv3c-6cw7-2qcq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:poll_scm:*:*:*:*:*:jenkins:*:*up to 1.3.1VulnerableJenkins
  • cpe:2.3:a:jenkins:poll_scm:*:*:*:*:*:jenkins:*:* Versions up to 1.3.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-fv3c-6cw7-2qcq org.jenkins-ci.plugins:pollscm (Maven) Fixed in 1.3.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000093
  2. 2026-10-03 Alias added: GHSA-fv3c-6cw7-2qcq

References

Sources