The Pipeline: Input Step Plugin by default allowed users with Item/Read access to a…
Priority LOW 35CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
The Pipeline: Input Step Plugin by default allowed users with Item/Read access to a pipeline to interact with the step to provide input. This has been changed, and now requires users to have the Item/Build permission instead.
Why it matters now
EPSS 0.01146 66th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins:pipeline-input-step (Maven): 2.7Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:pipeline-input-step (Maven) | before 2.7 | 2.7 | Patch available | GHSA-hxpw-7x95-q38m |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:pipeline-input-step (Maven) Vendor— Affected before 2.7 Fixed in 2.7 Patch available GHSA-hxpw-7x95-q38m
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins:pipeline-input-step:2.0:*:*:*:*:jenkins:*:* | 2.0 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:pipeline-input-step:2.1:*:*:*:*:jenkins:*:* | 2.1 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:pipeline-input-step:2.2:*:*:*:*:jenkins:*:* | 2.2 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:pipeline-input-step:2.3:*:*:*:*:jenkins:*:* | 2.3 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:pipeline-input-step:2.4:*:*:*:*:jenkins:*:* | 2.4 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:pipeline-input-step:2.5:*:*:*:*:jenkins:*:* | 2.5 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:pipeline-input-step:2.6:*:*:*:*:jenkins:*:* | 2.6 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:pipeline-input-step:2.7:*:*:*:*:jenkins:*:* | 2.7 | Vulnerable | Jenkins |
- cpe:2.3:a:jenkins:pipeline-input-step:2.0:*:*:*:*:jenkins:*:* Versions 2.0 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:pipeline-input-step:2.1:*:*:*:*:jenkins:*:* Versions 2.1 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:pipeline-input-step:2.2:*:*:*:*:jenkins:*:* Versions 2.2 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:pipeline-input-step:2.3:*:*:*:*:jenkins:*:* Versions 2.3 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:pipeline-input-step:2.4:*:*:*:*:jenkins:*:* Versions 2.4 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:pipeline-input-step:2.5:*:*:*:*:jenkins:*:* Versions 2.5 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:pipeline-input-step:2.6:*:*:*:*:jenkins:*:* Versions 2.6 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:pipeline-input-step:2.7:*:*:*:*:jenkins:*:* Versions 2.7 Vulnerable ·Jenkins
Remediation
- Fix · GHSA-hxpw-7x95-q38m org.jenkins-ci.plugins:pipeline-input-step (Maven) Fixed in 2.7 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000108
- 2026-10-03 Alias added: GHSA-hxpw-7x95-q38m
References
Sources
- CVE-2017-1000108 · CVE Program
- CVE-2017-1000108 · NVD
- FIRST EPSS
- GHSA-hxpw-7x95-q38m · GitHub Advisory Database · CC BY 4.0
- CVE-2017-1000108 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences