Elixir's vim plugin, alchemist.vim is vulnerable to remote code execution in the bundled…
Priority MEDIUM 47Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Elixir's vim plugin, alchemist.vim is vulnerable to remote code execution in the bundled alchemist-server. A malicious website can execute requests against an ephemeral port on localhost that are then evaluated as elixir code.
Why it matters now
EPSS 0.02885 86th percentileScored 2026-11-07
Fix Fixed alchemist.vim (Hex): 1.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | alchemist.vim (Hex) | before 1.3.2 | 1.3.2 | Patch available | GHSA-6x65-vqp7-5r63 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- alchemist.vim (Hex) Vendor— Affected before 1.3.2 Fixed in 1.3.2 Patch available GHSA-6x65-vqp7-5r63
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:alchemist-elixir:alchemist-server:-:*:*:*:*:vim:*:* | not specified by NVD | Vulnerable | Alchemist-elixir |
- cpe:2.3:a:alchemist-elixir:alchemist-server:-:*:*:*:*:vim:*:* Versions not specified by NVD Vulnerable ·Alchemist-elixir
Remediation
- Fix · GHSA-6x65-vqp7-5r63 alchemist.vim (Hex) Fixed in 1.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000212
- 2026-10-03 Alias added: GHSA-6x65-vqp7-5r63
References
Sources
- CVE-2017-1000212 · CVE Program
- CVE-2017-1000212 · NVD
- FIRST EPSS
- GHSA-6x65-vqp7-5r63 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences