Read the docs

Opencast 2.3.2 and older versions are vulnerable to script injections through media and…

Priority MEDIUM 42CWE-74Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

Opencast 2.3.2 and older versions are vulnerable to script injections through media and metadata in the player and media module resulting in arbitrary code execution, fixed in 2.3.3 and 3.0.

Why it matters now

EPSS 0.01878 79th percentileScored 2026-11-07
Fix Fixed org.opencastproject:base (Maven): 2.3.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.opencastproject:base (Maven)before 2.3.32.3.3Patch availableGHSA-qwfv-5jwj-582h
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.opencastproject:base (Maven) Vendor— Affected before 2.3.3 Fixed in 2.3.3 Patch available GHSA-qwfv-5jwj-582h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opencast:opencast:*:*:*:*:*:*:*:*up to 2.3.2Vulnerableopencast
  • cpe:2.3:a:opencast:opencast:*:*:*:*:*:*:*:* Versions up to 2.3.2 Vulnerable ·opencast

Remediation

  • Fix · GHSA-qwfv-5jwj-582h org.opencastproject:base (Maven) Fixed in 2.3.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000217
  2. 2026-10-03 Alias added: GHSA-qwfv-5jwj-582h

References

Sources