soyuka/pidusage <=1.1.4 is vulnerable to command injection in the module resulting in arbitrary command execution
Priority MEDIUM 50CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
soyuka/pidusage <=1.1.4 is vulnerable to command injection in the module resulting in arbitrary command execution
Why it matters now
EPSS 0.05056 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pidusage (npm): 1.1.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pidusage (npm) | before 1.1.5 | 1.1.5 | Patch available | GHSA-h2p3-h48h-9jj7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pidusage (npm) Vendor— Affected before 1.1.5 Fixed in 1.1.5 Patch available GHSA-h2p3-h48h-9jj7
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pidusage_project:pidusage:*:*:*:*:*:*:*:* | up to 1.1.4 | Vulnerable | Pidusage Project |
- cpe:2.3:a:pidusage_project:pidusage:*:*:*:*:*:*:*:* Versions up to 1.1.4 Vulnerable ·Pidusage Project
Remediation
- Fix · GHSA-h2p3-h48h-9jj7 pidusage (npm) Fixed in 1.1.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000220
- 2026-10-03 Alias added: GHSA-h2p3-h48h-9jj7
References
Sources
- CVE-2017-1000220 · CVE Program
- CVE-2017-1000220 · NVD
- FIRST EPSS
- GHSA-h2p3-h48h-9jj7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences