Jenkins Dependency Graph Viewer plugin 0.12 and earlier did not perform permission checks…
Priority LOW 21CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Jenkins Dependency Graph Viewer plugin 0.12 and earlier did not perform permission checks for the API endpoint that modifies the dependency graph, allowing anyone with Overall/Read permission to modify this data.
Why it matters now
EPSS 0.0063 50th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:depgraph-view (Maven): 0.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:depgraph-view (Maven) | before 0.13 | 0.13 | Patch available | GHSA-vhh3-mvc4-hhq6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:depgraph-view (Maven) Vendor— Affected before 0.13 Fixed in 0.13 Patch available GHSA-vhh3-mvc4-hhq6
Remediation
- Fix · GHSA-vhh3-mvc4-hhq6 org.jenkins-ci.plugins:depgraph-view (Maven) Fixed in 0.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000388
- 2026-10-03 Alias added: GHSA-vhh3-mvc4-hhq6
- 2026-10-28 EPSS moved to the 50th–90th percentile
References
More Jenkins Dependency Graph Viewer vulnerabilities
- TI-2019-07658 Cross-site scripting in Jenkins Dependency Graph Viewer Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2017-1000388 · CVE Program
- CVE-2017-1000388 · NVD
- FIRST EPSS
- GHSA-vhh3-mvc4-hhq6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences