pysaml2 version 4.4.0 and older accept any password when run with python optimizations…
Priority MEDIUM 40CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 6 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287.
Summary
pysaml2 version 4.4.0 and older accept any password when run with python optimizations enabled. This allows attackers to log in as any user without knowing their password.
Why it matters now
EPSS 0.02553 85th percentileScored 2026-11-07
Fix Partial pysaml2 (PyPI): 4.5.0Red Hat: 6 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pysaml2 (PyPI) | before 4.5.0 | 4.5.0 | Patch available | GHSA-924m-4pmx-c67h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pysaml2 (PyPI) Vendor— Affected before 4.5.0 Fixed in 4.5.0 Patch available GHSA-924m-4pmx-c67h
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pysaml2_project:pysaml2:*:*:*:*:*:*:*:* | up to 4.4.0 | Vulnerable | Pysaml2 Project |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:pysaml2_project:pysaml2:*:*:*:*:*:*:*:* Versions up to 4.4.0 Vulnerable ·Pysaml2 Project
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-924m-4pmx-c67h pysaml2 (PyPI) Fixed in 4.5.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 11 (Ocata) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 12 (Pike) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 8 (Liberty) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 9 (Mitaka) | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000433
- 2026-10-03 Alias added: GHSA-924m-4pmx-c67h
References
Advisory 5
Sources
- CVE-2017-1000433 · CVE Program
- CVE-2017-1000433 · NVD
- FIRST EPSS
- GHSA-924m-4pmx-c67h · GitHub Advisory Database · CC BY 4.0
- CVE-2017-1000433 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences