In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not…
Priority MEDIUM 44CWE-190Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-190 and the CVSS impact.
Summary
In opencv/modules/imgcodecs/src/utils.cpp, functions FillUniColor and FillUniGray do not check the input length, which can lead to integer overflow. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 and earlier.
Why it matters now
EPSS 0.03261 88th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Partial opencv-python (PyPI): 3.3.1.11opencv-contrib-python (PyPI): 3.3.1.11Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | opencv-python (PyPI) | before 3.3.1.11 | 3.3.1.11 | Patch available | GHSA-m43c-649m-pm48 |
| — | opencv-contrib-python (PyPI) | before 3.3.1.11 | 3.3.1.11 | Patch available | GHSA-m43c-649m-pm48 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- opencv-python (PyPI) Vendor— Affected before 3.3.1.11 Fixed in 3.3.1.11 Patch available GHSA-m43c-649m-pm48
- opencv-contrib-python (PyPI) Vendor— Affected before 3.3.1.11 Fixed in 3.3.1.11 Patch available GHSA-m43c-649m-pm48
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opencv:opencv:*:*:*:*:*:*:*:* | up to 3.3.0 | Vulnerable | OpenCV |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:opencv:opencv:*:*:*:*:*:*:*:* Versions up to 3.3.0 Vulnerable ·OpenCV
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-m43c-649m-pm48 opencv-python (PyPI) Fixed in 3.3.1.11 Advisory →
- Fix · GHSA-m43c-649m-pm48 opencv-contrib-python (PyPI) Fixed in 3.3.1.11 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000450
- 2026-10-03 Alias added: GHSA-m43c-649m-pm48
References
Exploit 2
Advisory 4
Sources
- CVE-2017-1000450 · CVE Program
- CVE-2017-1000450 · NVD
- FIRST EPSS
- GHSA-m43c-649m-pm48 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-1000450 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences