An XML Signature Wrapping vulnerability exists in Samlify 2.2.0 and earlier, and in…
Priority LOW 36CWE-91Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
An XML Signature Wrapping vulnerability exists in Samlify 2.2.0 and earlier, and in predecessor Express-saml2 which could allow attackers to impersonate arbitrary users.
Why it matters now
EPSS 0.0138 72nd percentileScored 2026-11-07
Fix Fixed samlify (npm): 2.4.0-rc5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | samlify (npm) | before 2.4.0-rc5 | 2.4.0-rc5 | Patch available | GHSA-8jjf-w7j6-323c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- samlify (npm) Vendor— Affected before 2.4.0-rc5 Fixed in 2.4.0-rc5 Patch available GHSA-8jjf-w7j6-323c
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:samlify_project:samlify:*:*:*:*:*:*:*:* | up to 2.2.0 | Vulnerable | Samlify Project |
- cpe:2.3:a:samlify_project:samlify:*:*:*:*:*:*:*:* Versions up to 2.2.0 Vulnerable ·Samlify Project
Remediation
- Fix · GHSA-8jjf-w7j6-323c samlify (npm) Fixed in 2.4.0-rc5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000452
- 2026-10-03 Alias added: GHSA-8jjf-w7j6-323c
References
Advisory 2
More Samlify Project Samlify vulnerabilities
- TI-2026-34189 samlify: XML Injection in AttributeValue Allows Privilege Escalation in Signed SAML Assertions CVSS 4.0HIGH 8.7
- TI-2025-30342 samlify SAML Signature Wrapping attack CVSS 4.0CRITICAL 9.9
Sources
- CVE-2017-1000452 · CVE Program
- CVE-2017-1000452 · NVD
- FIRST EPSS
- GHSA-8jjf-w7j6-323c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences