Read the docs

pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error…

Priority MEDIUM 62CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-352.

Summary

pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under "possibly insecure" suspicions.

Why it matters now

EPSS 0.31701 98th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:netgate:pfsense:*:*:*:*:*:*:*:*up to 2.4.1VulnerableNetgate
cpe:2.3:a:opnsense_project:opnsense:*:*:*:*:*:*:*:*before 16.1.16VulnerableOpnsense Project
  • cpe:2.3:a:netgate:pfsense:*:*:*:*:*:*:*:* Versions up to 2.4.1 Vulnerable ·Netgate
  • cpe:2.3:a:opnsense_project:opnsense:*:*:*:*:*:*:*:* Versions before 16.1.16 Vulnerable ·Opnsense Project

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000479
  2. 2026-10-03 Alias added: GHSA-vh6j-wmcp-r6j7

References

Sources