Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or…
Priority MEDIUM 48CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.
Why it matters now
EPSS 0.03124 87th percentileScored 2026-11-07
Fix Fixed smarty/smarty (Packagist): 3.1.32
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | smarty/smarty (Packagist) | 3 to before 3.1.32 | 3.1.32 | Patch available | GHSA-9m49-vhwv-422g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- smarty/smarty (Packagist) Vendor— Affected 3 to before 3.1.32 Fixed in 3.1.32 Patch available GHSA-9m49-vhwv-422g
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:smarty:smarty:*:*:*:*:*:*:*:* | 3.0.0 to before 3.1.32 | Vulnerable | smarty-php |
- cpe:2.3:a:smarty:smarty:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.1.32 Vulnerable ·smarty-php
Remediation
- Fix · GHSA-9m49-vhwv-422g smarty/smarty (Packagist) Fixed in 3.1.32 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000480
- 2026-10-03 Alias added: GHSA-9m49-vhwv-422g
References
Advisory 3
More smarty-php Smarty vulnerabilities
- TI-2021-08070 Smarty before 3.1.39 allows code injection via an unexpected function name after a {function name= substring. CVSS 3.1CRITICAL 9.8
- TI-2009-01585 The smarty_function_math function in libs/plugins/function.math.php in Smarty 2.6.22… CVSS 2.0HIGH 10.0
- TI-2006-06846 PHP remote file inclusion vulnerability in libs/Smarty.class.php in Smarty 2.6.9 allows… CVSS 3.1CRITICAL 9.8
- TI-2022-11764 PHP Code Injection by malicious block or filename in Smarty CVSS 3.1HIGH 8.8
- TI-2010-04450 Smarty before 3.0.0 beta 7 does not properly handle the <?php and ?> tags, which has… CVSS 2.0HIGH 10.0
- TI-2010-04449 Unspecified vulnerability in the math plugin in Smarty before 3.0.0 RC1 has unknown… CVSS 2.0HIGH 10.0
Sources
- CVE-2017-1000480 · CVE Program
- CVE-2017-1000480 · NVD
- FIRST EPSS
- GHSA-9m49-vhwv-422g · GitHub Advisory Database · CC BY 4.0
- CVE-2017-1000480 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences