Primetek Primefaces 5.x is vulnerable to a weak encryption flaw resulting in remote code execution
Priority CRITICAL 100Exploited in the wildCWE-326Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-326.
Summary
Primetek Primefaces 5.x is vulnerable to a weak encryption flaw resulting in remote code execution
Why it matters now
Exploitation Active In CISA KEV since 2022-01-10CISA due date 2022-07-10
EPSS 0.94104 99th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD and the CNA
Fix Fixed org.primefaces:primefaces (Maven): 6.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.primefaces:primefaces (Maven) | 5.0 to before 6.0 | 6.0 | Patch available | GHSA-j239-4gqg-5j54 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.primefaces:primefaces (Maven) Vendor— Affected 5.0 to before 6.0 Fixed in 6.0 Patch available GHSA-j239-4gqg-5j54
Remediation
- Fix · GHSA-j239-4gqg-5j54 org.primefaces:primefaces (Maven) Fixed in 6.0 Advisory →
Timeline
- 2022-01-10 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2017-1000486
- 2026-10-03 Alias added: GHSA-j239-4gqg-5j54
References
Advisory 3
More Primetek Primefaces vulnerabilities
- TI-2020-08464 An XSS issue was discovered in tooltip/tooltip.js in PrimeTek PrimeFaces 7.0.11. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2017-1000486 · CVE Program
- CVE-2017-1000486 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-j239-4gqg-5j54 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences