Read the docs

Plexus-utils before 3.0.16 is vulnerable to command injection because it does not…

Priority MEDIUM 51CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 fixed, 8 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-78.

Summary

Plexus-utils before 3.0.16 is vulnerable to command injection because it does not correctly process the contents of double quoted strings.

Why it matters now

EPSS 0.0649 93rd percentileScored 2026-11-07
Fix Partial org.codehaus.plexus:plexus-utils (Maven): 3.0.16Red Hat: 1 advisoryRed Hat: 2 fixed, 8 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.codehaus.plexus:plexus-utils (Maven)before 3.0.163.0.16Patch availableGHSA-8vhq-qq4p-grq3
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.codehaus.plexus:plexus-utils (Maven) Vendor— Affected before 3.0.16 Fixed in 3.0.16 Patch available GHSA-8vhq-qq4p-grq3

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:codehaus-plexus:plexus-utils:*:*:*:*:*:*:*:*before 3.0.16Vulnerablecodehaus-plexus
cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*7.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:codehaus-plexus:plexus-utils:*:*:*:*:*:*:*:* Versions before 3.0.16 Vulnerable ·codehaus-plexus
  • cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-8vhq-qq4p-grq3 org.codehaus.plexus:plexus-utils (Maven) Fixed in 3.0.16 Advisory →

Red Hat 1 advisory

  • RHSA-2018:1322 Released 2018-05-03 · Red Hat rating Moderate
    Red Hat JBoss Fuse/A-MQ 6.3 R7 security and bug fix update
    • Red Hat JBoss A-MQ 6.3
    • Red Hat JBoss Fuse 6.3

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
JBoss Developer Studio 10Affected—
JBoss Developer Studio 8Affected—
Red Hat Enterprise Linux 7AffectedNo fix planned: Will not fix
Red Hat JBoss A-MQ 6AffectedNo fix yet
Red Hat JBoss Fuse Service Works 6AffectedNo fix planned: Will not fix
Red Hat JBoss Portal 6Affected—
Red Hat OpenStack Platform 8 (Liberty)AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 9 (Mitaka)AffectedNo fix planned: Will not fix
Red Hat JBoss A-MQ 6.3Fixed RHSA-2018:1322
Red Hat JBoss Fuse 6.3Fixed RHSA-2018:1322
Not affected: 7 products
  • Red Hat BPM Suite 6
  • Red Hat Enterprise Linux 8
  • Red Hat JBoss BRMS 6
  • Red Hat JBoss Data Virtualization 6
  • Red Hat Satellite 6
  • Red Hat Single Sign-On 7
  • Red Hat Software Collections

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000487
  2. 2026-10-03 Alias added: GHSA-8vhq-qq4p-grq3

References

Sources