Code injection in Fedora Project Infrastructure Bodhi
Priority LOW 29CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution, Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94 and CWE-79.
Summary
Bodhi 2.9.0 and lower is vulnerable to cross-site scripting resulting in code injection caused by incorrect validation of bug titles.
Why it matters now
EPSS 0.00787 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed bodhi (PyPI): 2.9.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Fedora Project Infrastructure | Bodhi | up to 2.9.0 | — | No fix listed | CNA |
| — | bodhi (PyPI) | before 2.9.1 | 2.9.1 | Patch available | GHSA-h896-6hcp-gj6c |
- Bodhi VendorFedora Project Infrastructure Affected up to 2.9.0 Fixed in — No fix listed CNA
- bodhi (PyPI) Vendor— Affected before 2.9.1 Fixed in 2.9.1 Patch available GHSA-h896-6hcp-gj6c
Remediation
- Fix · GHSA-h896-6hcp-gj6c bodhi (PyPI) Fixed in 2.9.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1002152
- 2026-10-03 Alias added: GHSA-h896-6hcp-gj6c
References
More Red Hat Bodhi vulnerabilities
- TI-2020-12477 Two cross-site scripting vulnerabilities were fixed in Bodhi 5.6.1. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2017-1002152 · CVE Program
- CVE-2017-1002152 · NVD
- FIRST EPSS
- GHSA-h896-6hcp-gj6c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences