Improper input validation in Fedora Modularity modulemd
Priority MEDIUM 47CWE-242Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
modulemd 1.3.1 and earlier uses an unsafe function for processing externally provided data, leading to remote code execution.
Why it matters now
EPSS 0.02882 86th percentileScored 2026-11-07
Fix Fixed modulemd (PyPI): 1.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Fedora Modularity | modulemd | up to 1.3.1 | — | No fix listed | CNA |
| — | modulemd (PyPI) | before 1.3.2 | 1.3.2 | Patch available | GHSA-jhjh-ghwx-6h7r |
- modulemd VendorFedora Modularity Affected up to 1.3.1 Fixed in — No fix listed CNA
- modulemd (PyPI) Vendor— Affected before 1.3.2 Fixed in 1.3.2 Patch available GHSA-jhjh-ghwx-6h7r
Remediation
- Fix · GHSA-jhjh-ghwx-6h7r modulemd (PyPI) Fixed in 1.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1002157
- 2026-10-03 Alias added: GHSA-jhjh-ghwx-6h7r
References
Sources
- CVE-2017-1002157 · CVE Program
- CVE-2017-1002157 · NVD
- FIRST EPSS
- GHSA-jhjh-ghwx-6h7r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences