Local file inclusion in Broadstreet Ad Widget WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-98.
Summary
The Broadstreet Ad Widget plugin for WordPress from 2.2.0 before 2.12.0 contains a local file inclusion flaw. Improper control of a filename in a PHP require statement (CWE-98) lets authenticated users run attacker-chosen PHP files. Attackers can pass directory traversal sequences through the step parameter, optionally with a null byte, to include local files and execute PHP code. The Shadowserver Foundation first observed exploitation on 2023-10-19, and a public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
Broadstreet Ad Widget plugin for WordPress 2.2.0 before 2.12.0 contains a local file inclusion vulnerability that allows authenticated users to execute attacker-chosen PHP files by passing unsanitized input to require in views/modal/index.php. Attackers can supply directory traversal sequences in the 'step' parameter, optionally with a null byte, to include local files and execute PHP code. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Broadstreet | Ad Widget | 2.2.0 to before 2.12.0 | 2.12.0 | Patch available | CNA |
- Ad Widget VendorBroadstreet Affected 2.2.0 to before 2.12.0 Fixed in 2.12.0 Patch available CNA
Remediation
Update Broadstreet Ad Widget to version 2.12.0, the fixed version for this plugin.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA Ad Widget (Broadstreet) Fixed in 2.12.0
Timeline
- 2026-10-22 Threatist record created from CVE-2017-20289
- 2026-10-22 Alias added: GHSA-p32h-85vq-6f9p
- 2026-10-23 Priority changed: MEDIUM → LOW
- 2026-10-23 CISA SSVC decision points changed
- 2026-10-24 Priority changed: LOW → HIGH
References
Exploit 1
Patch 1
Advisory 1
More Broadstreet vulnerabilities
- TI-2025-42754 WordPress Broadstreet Ads plugin <= 1.52.1 - Broken Access Control vulnerability CVSS 3.1HIGH 7.6
- TI-2025-30483 WordPress Broadstreet plugin <= 1.51.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-23308 WordPress Broadstreet plugin <= 1.52.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2026-33027 WordPress Broadstreet Ads plugin <= 1.52.2 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.4
- TI-2025-23367 WordPress Broadstreet plugin <= 1.52.1 - Cross Site Request Forgery (CSRF) to Settings Change vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2017-20289 · CVE Program
- CVE-2017-20289 · NVD
- FIRST EPSS
- GHSA-p32h-85vq-6f9p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences