Read the docs
TI-2018-00456 Aliases CVE-2018-0499GHSA-7qw4-w7hf-22q3

Cross-site scripting in Xapian xapian-core before 1.4.6

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().

Why it matters now

EPSS 0.01043 64th percentileScored 2026-11-07
Fix Fixed xapian-core (RubyGems): 1.4.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Xapian xapian-core before 1.4.6Xapian xapian-core before 1.4.6—No fix listedCNA
—xapian-core (RubyGems)before 1.4.61.4.6Patch availableGHSA-7qw4-w7hf-22q3
  • Xapian xapian-core before 1.4.6 Vendor— Affected Xapian xapian-core before 1.4.6 Fixed in — No fix listed CNA
  • xapian-core (RubyGems) Vendor— Affected before 1.4.6 Fixed in 1.4.6 Patch available GHSA-7qw4-w7hf-22q3

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:xapian:xapian-core:*:*:*:*:*:*:*:*before 1.4.6VulnerableXapian
cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:*17.10VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*18.04VulnerableCanonical
  • cpe:2.3:a:xapian:xapian-core:*:*:*:*:*:*:*:* Versions before 1.4.6 Vulnerable ·Xapian
  • cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* Versions 17.10 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical

Remediation

  • Fix · GHSA-7qw4-w7hf-22q3 xapian-core (RubyGems) Fixed in 1.4.6 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat Enterprise Linux 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-0499
  2. 2026-10-03 Alias added: GHSA-7qw4-w7hf-22q3

References

Sources