$wgRateLimits entry for 'user' overrides 'newbie'
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 3 fixed, 3 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-269.
Summary
Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where contrary to the documentation, $wgRateLimits entry for 'user' overrides that for 'newbie'.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| mediawiki | mediawiki | before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 | — | No fix listed | CNA |
| — | mediawiki/core (Packagist) | 1.27.0 to before 1.27.5 | 1.27.5 | Patch available | GHSA-mhfv-9h99-jwg7 |
| — | mediawiki/core (Packagist) | 1.29.0 to before 1.29.3 | 1.29.3 | Patch available | GHSA-mhfv-9h99-jwg7 |
| — | mediawiki/core (Packagist) | 1.30.0 to before 1.30.1 | 1.30.1 | Patch available | GHSA-mhfv-9h99-jwg7 |
| — | mediawiki/core (Packagist) | 1.31.0 to before 1.31.1 | 1.31.1 | Patch available | GHSA-mhfv-9h99-jwg7 |
- mediawiki Vendormediawiki Affected before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 Fixed in — No fix listed CNA
- mediawiki/core (Packagist) Vendor— Affected 1.27.0 to before 1.27.5 Fixed in 1.27.5 Patch available GHSA-mhfv-9h99-jwg7
- mediawiki/core (Packagist) Vendor— Affected 1.29.0 to before 1.29.3 Fixed in 1.29.3 Patch available GHSA-mhfv-9h99-jwg7
- mediawiki/core (Packagist) Vendor— Affected 1.30.0 to before 1.30.1 Fixed in 1.30.1 Patch available GHSA-mhfv-9h99-jwg7
- mediawiki/core (Packagist) Vendor— Affected 1.31.0 to before 1.31.1 Fixed in 1.31.1 Patch available GHSA-mhfv-9h99-jwg7
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* | 1.31.0 to before 1.31.1 | Vulnerable | mediawiki |
| cpe:2.3:a:mediawiki:mediawiki:1.27.5:*:*:*:*:*:*:* | 1.27.5 | Vulnerable | mediawiki |
| cpe:2.3:a:mediawiki:mediawiki:1.29.3:*:*:*:*:*:*:* | 1.29.3 | Vulnerable | mediawiki |
| cpe:2.3:a:mediawiki:mediawiki:1.30.1:*:*:*:*:*:*:* | 1.30.1 | Vulnerable | mediawiki |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.31.0 to before 1.31.1 Vulnerable ·mediawiki
- cpe:2.3:a:mediawiki:mediawiki:1.27.5:*:*:*:*:*:*:* Versions 1.27.5 Vulnerable ·mediawiki
- cpe:2.3:a:mediawiki:mediawiki:1.29.3:*:*:*:*:*:*:* Versions 1.29.3 Vulnerable ·mediawiki
- cpe:2.3:a:mediawiki:mediawiki:1.30.1:*:*:*:*:*:*:* Versions 1.30.1 Vulnerable ·mediawiki
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-mhfv-9h99-jwg7 mediawiki/core (Packagist) Fixed in 1.27.5 Advisory →
- Fix · GHSA-mhfv-9h99-jwg7 mediawiki/core (Packagist) Fixed in 1.29.3 Advisory →
- Fix · GHSA-mhfv-9h99-jwg7 mediawiki/core (Packagist) Fixed in 1.30.1 Advisory →
- Fix · GHSA-mhfv-9h99-jwg7 mediawiki/core (Packagist) Fixed in 1.31.1 Advisory →
Red Hat 3 advisories
- RHSA-2019:3813 Released 2019-11-07 · Red Hat rating LowOpenShift Container Platform 3.9 mediawiki123 security update
- Red Hat OpenShift Container Platform 3.9 mediawiki123-1.23.17-1.el7, mediawiki123-doc-1.23.17-1.el7
- RHSA-2019:3238 Released 2019-10-29 · Red Hat rating LowOpenShift Container Platform 3.10 mediawiki security update
- Red Hat OpenShift Container Platform 3.10 mediawiki-1.27.7-1.el7, mediawiki-doc-1.27.7-1.el7
- RHSA-2019:3142 Released 2019-10-18 · Red Hat rating LowOpenShift Container Platform 3.11 mediawiki security update
- Red Hat OpenShift Container Platform 3.11 mediawiki-1.27.7-1.el7, mediawiki-doc-1.27.7-1.el7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
mediawiki — RHSA-2019:3238
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2018-00461 Information disclosure in Special:Redirect/logidPriority LOW 34
- TI-2018-00462 BotPasswords can bypass CentralAuth's account lockPriority LOW 33
- Advisory ·
mediawiki — RHSA-2019:3813
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2018-00461 Information disclosure in Special:Redirect/logidPriority LOW 34
- TI-2018-00462 BotPasswords can bypass CentralAuth's account lockPriority LOW 33
Show 2 more groups
- Advisory ·
mediawiki — DSA-4301
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2018-00461 Information disclosure in Special:Redirect/logidPriority LOW 34
- TI-2018-00462 BotPasswords can bypass CentralAuth's account lockPriority LOW 33
- Advisory ·
mediawiki — RHSA-2019:3142
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2018-00462 BotPasswords can bypass CentralAuth's account lockPriority LOW 33
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.6 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 3.7 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 3.10 | Fixed | RHSA-2019:3238 |
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2019:3142 |
| Red Hat OpenShift Container Platform 3.9 | Fixed | RHSA-2019:3813 |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-0503
- 2026-10-03 Alias added: GHSA-mhfv-9h99-jwg7
References
Patch 2
Advisory 5
More Mediawiki vulnerabilities
- TI-2023-18933 An issue was discovered in the CheckUser extension for MediaWiki through 1.39.3. CVSS 3.1CRITICAL 9.8
- TI-2023-13576 An issue was discovered in MediaWiki before 1.35.10, 1.36.x through 1.38.x before 1.38.6… CVSS 3.1CRITICAL 9.8
- TI-2023-03312 Stored XSS leads to privilege escalation in MediaWiki v1.40.0 CVSS 3.1CRITICAL 9.0
- TI-2026-42109 Cross-site request forgery in Wikimedia Foundation Mediawiki - RedirectManager Extension CVSS 4.0MEDIUM 6.9
- TI-2024-22822 An issue was discovered in includes/CommentFormatter/CommentParser.php in MediaWiki… CVSS 3.1HIGH 7.4
- TI-2023-18935 An issue was discovered in the ProofreadPage (aka Proofread Page) extension for MediaWiki… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2018-0503 · CVE Program
- CVE-2018-0503 · NVD
- FIRST EPSS
- GHSA-mhfv-9h99-jwg7 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-0503 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences