Improper authentication in Red Hat PackageKit
Priority LOW 25CWE-287Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-287.
Summary
An authentication bypass flaw has been found in PackageKit before 1.1.10 that allows users without administrator privileges to install signed packages. A local attacker can use this vulnerability to install vulnerable packages to further compromise a system.
Why it matters now
EPSS 0.00379 32nd percentileScored 2026-11-07
Fix Fixed Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | PackageKit | before 1.1.10 | 1.1.10 | Patch available | CNA |
- PackageKit VendorRed Hat Affected before 1.1.10 Fixed in 1.1.10 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:packagekit_project:packagekit:*:*:*:*:*:*:*:* | before 1.1.10 | Vulnerable | PackageKit |
| cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_aus:7.6:*:*:*:*:*:*:* | 7.6 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_eus:7.5:*:*:*:*:*:*:* | 7.5 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_eus:7.6:*:*:*:*:*:*:* | 7.6 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_tus:7.6:*:*:*:*:*:*:* | 7.6 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* | 17.10 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:packagekit_project:packagekit:*:*:*:*:*:*:*:* Versions before 1.1.10 Vulnerable ·PackageKit
- cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_aus:7.6:*:*:*:*:*:*:* Versions 7.6 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_eus:7.5:*:*:*:*:*:*:* Versions 7.5 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_eus:7.6:*:*:*:*:*:*:* Versions 7.6 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_tus:7.6:*:*:*:*:*:*:* Versions 7.6 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* Versions 17.10 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
Red Hat 1 advisory
- RHSA-2018:1224 Released 2018-04-24 · Red Hat rating ModeratePackageKit security update
- Red Hat Enterprise Linux Client (v. 7) PackageKit-1.1.5-2.el7_5, PackageKit-command-not-found-1.1.5-2.el7_5, PackageKit-glib-1.1.5-2.el7_5 +3
- Red Hat Enterprise Linux Client Optional (v. 7) PackageKit-1.1.5-2.el7_5, PackageKit-cron-1.1.5-2.el7_5, PackageKit-glib-devel-1.1.5-2.el7_5 +1
- Red Hat Enterprise Linux ComputeNode (v. 7) PackageKit-1.1.5-2.el7_5, PackageKit-glib-1.1.5-2.el7_5
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) PackageKit-1.1.5-2.el7_5, PackageKit-command-not-found-1.1.5-2.el7_5, PackageKit-cron-1.1.5-2.el7_5 +5
- Red Hat Enterprise Linux Server (v. 7) PackageKit-1.1.5-2.el7_5, PackageKit-command-not-found-1.1.5-2.el7_5, PackageKit-glib-1.1.5-2.el7_5 +5
- Red Hat Enterprise Linux Server Optional (v. 7) PackageKit-1.1.5-2.el7_5, PackageKit-1.1.5-2.el7_5.ppc, PackageKit-cron-1.1.5-2.el7_5 +3
- Red Hat Enterprise Linux Workstation (v. 7) PackageKit-1.1.5-2.el7_5, PackageKit-command-not-found-1.1.5-2.el7_5, PackageKit-glib-1.1.5-2.el7_5 +3
- Red Hat Enterprise Linux Workstation Optional (v. 7) PackageKit-1.1.5-2.el7_5, PackageKit-cron-1.1.5-2.el7_5, PackageKit-glib-devel-1.1.5-2.el7_5 +1
- Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server (v. 7) PackageKit-1.1.5-2.el7_5, PackageKit-command-not-found-1.1.5-2.el7_5, PackageKit-glib-1.1.5-2.el7_5 +3
- Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server Optional (v. 7) PackageKit-1.1.5-2.el7_5, PackageKit-cron-1.1.5-2.el7_5, PackageKit-glib-devel-1.1.5-2.el7_5 +1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2018:1224 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2018:1224 |
| Red Hat Enterprise Linux ComputeNode (v. 7) | Fixed | RHSA-2018:1224 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2018:1224 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2018:1224 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2018:1224 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2018:1224 |
| Red Hat Enterprise Linux Workstation Optional (v. 7) | Fixed | RHSA-2018:1224 |
| Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server (v. 7) | Fixed | RHSA-2018:1224 |
| Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server Optional (v. 7) | Fixed | RHSA-2018:1224 |
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1106
- 2026-10-03 Alias added: GHSA-9pvg-w7xf-pgq7
References
More Red Hat Enterprise Linux Desktop vulnerabilities
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2018-1106 · CVE Program
- CVE-2018-1106 · NVD
- FIRST EPSS
- GHSA-9pvg-w7xf-pgq7 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1106 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences