Cross-site scripting in Pivotal Cloud Foundry products: all versions prior to cf-release…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An issue was discovered in these Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0. A cross-site scripting (XSS) attack is possible in the clientId parameter of a request to the UAA OpenID Connect check session iframe endpoint used for single logout session management.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0 | Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0 | — | No fix listed | CNA |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | 3.0.0 to before 3.20.2 | 3.20.2 | Patch available | GHSA-j97q-9xp9-g5fx |
- Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0 Vendor— Affected Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0 Fixed in — No fix listed CNA
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected 3.0.0 to before 3.20.2 Fixed in 3.20.2 Patch available GHSA-j97q-9xp9-g5fx
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudfoundry:cf-release:*:*:*:*:*:*:*:* | up to 269 | Vulnerable | CloudFoundry Foundation |
| cpe:2.3:a:pivotal:uaa:*:*:*:*:*:*:*:* | 3.0.0 – 3.20.1 | Vulnerable | Pivotal |
| cpe:2.3:a:pivotal:uaa_bosh:*:*:*:*:*:*:*:* | up to 44 | Vulnerable | Pivotal |
- cpe:2.3:a:cloudfoundry:cf-release:*:*:*:*:*:*:*:* Versions up to 269 Vulnerable ·CloudFoundry Foundation
- cpe:2.3:a:pivotal:uaa:*:*:*:*:*:*:*:* Versions 3.0.0 – 3.20.1 Vulnerable ·Pivotal
- cpe:2.3:a:pivotal:uaa_bosh:*:*:*:*:*:*:*:* Versions up to 44 Vulnerable ·Pivotal
Remediation
- Fix · GHSA-j97q-9xp9-g5fx org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 3.20.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1190
- 2026-10-03 Alias added: GHSA-j97q-9xp9-g5fx
References
Sources
- CVE-2018-1190 · CVE Program
- CVE-2018-1190 · NVD
- FIRST EPSS
- GHSA-j97q-9xp9-g5fx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences