Infinite loop in Apache Commons Compress
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-835.
Summary
A specially crafted ZIP archive can be used to cause an infinite loop inside of Apache Commons Compress' extra field parser used by the ZipFile and ZipArchiveInputStream classes in versions 1.11 to 1.15. This can be used to mount a denial of service attack against services that use Compress' zip package.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Commons Compress | 1.11 to 1.15 | — | No fix listed | CNA |
| — | org.apache.commons:commons-compress (Maven) | 1.11 to before 1.16 | 1.16 | Patch available | GHSA-h436-432x-8fvx |
| — | com.liferay:com.liferay.portal.tools.bundle.support (Maven) | 3.2.7 to before 3.7.4 | 3.7.4 | Patch available | GHSA-h436-432x-8fvx |
| — | io.takari:commons-compress (Maven) | — | — | No fix listed | GHSA-h436-432x-8fvx |
- Apache Commons Compress VendorApache Affected 1.11 to 1.15 Fixed in — No fix listed CNA
- org.apache.commons:commons-compress (Maven) Vendor— Affected 1.11 to before 1.16 Fixed in 1.16 Patch available GHSA-h436-432x-8fvx
- com.liferay:com.liferay.portal.tools.bundle.support (Maven) Vendor— Affected 3.2.7 to before 3.7.4 Fixed in 3.7.4 Patch available GHSA-h436-432x-8fvx
- io.takari:commons-compress (Maven) Vendor— Affected — Fixed in — No fix listed GHSA-h436-432x-8fvx
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:commons_compress:*:*:*:*:*:*:*:* | 1.11 – 1.15 | Vulnerable | Apache |
| cpe:2.3:a:oracle:mysql_cluster:*:*:*:*:*:*:*:* | up to 7.4.34; 7.5.0 – 7.5.24; 7.6.0 – 7.6.20; 8.0.0 – 8.0.27 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:weblogic_server:14.1.1.0.0:*:*:*:*:*:*:* | 14.1.1.0.0 | Vulnerable | Oracle |
- cpe:2.3:a:apache:commons_compress:*:*:*:*:*:*:*:* Versions 1.11 – 1.15 Vulnerable ·Apache
- cpe:2.3:a:oracle:mysql_cluster:*:*:*:*:*:*:*:* Versions up to 7.4.34; 7.5.0 – 7.5.24; 7.6.0 – 7.6.20; 8.0.0 – 8.0.27 Vulnerable ·Oracle
- cpe:2.3:a:oracle:weblogic_server:14.1.1.0.0:*:*:*:*:*:*:* Versions 14.1.1.0.0 Vulnerable ·Oracle
Remediation
- Fix · GHSA-h436-432x-8fvx org.apache.commons:commons-compress (Maven) Fixed in 1.16 Advisory →
- Fix · GHSA-h436-432x-8fvx com.liferay:com.liferay.portal.tools.bundle.support (Maven) Fixed in 3.7.4 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat JBoss Data Virtualization 6 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 8 (Liberty) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 9 (Mitaka) | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
Not affected: 14 products
- JBoss Developer Studio 11
- Red Hat BPM Suite 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat JBoss BRMS 5
- Red Hat JBoss BRMS 6
- Red Hat JBoss Fuse 6
- Red Hat JBoss Fuse Service Works 6
- Red Hat Mobile Application Platform 4
- Red Hat OpenShift Application Runtimes
- Red Hat Satellite 6
- Red Hat Software Collections
- Red Hat Storage 3
- Red Hat Virtualization 4
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1324
- 2026-10-03 Alias added: GHSA-h436-432x-8fvx
References
Advisory 2
Other 12
- [dev] 20180316 [CVE-2018-1324] Apache Commons Compress denial of service vulnerability
- [pulsar-commits] 20190416 [GitHub] [pulsar] one70six opened a new issue #4057: Security Vulnerabilities - Black Duck Scan - Pulsar v.2.3.1
- [creadur-dev] 20190530 [Discuss] RAT-244 - update to language level 1.7 due to CVE issues in RAT
- [beam-issues] 20200421 [jira] [Closed] (BEAM-3873) Current version of commons-compress is DOS vulnerable CVE-2018-1324
- https://github.com/apache/commons-compress/commit/2a2f1dc48e22a34ddb72321a4db211da91aa933b
- https://arxiv.org/pdf/2306.05534.pdf
- https://github.com/apache/commons-compress
- https://github.com/jensdietrich/xshady-release/tree/main/CVE-2018-1324
- https://lists.apache.org/thread.html/1c7b6df6d1c5c8583518a0afa017782924918e4d6acfaf23ed5b2089@%3Cdev.commons.apache.org%3E
- https://lists.apache.org/thread.html/b8ef29df0f1d55aa741170748352ae8e425c7b1d286b2f257711a2dd@%3Cdev.creadur.apache.org%3E
- https://lists.apache.org/thread.html/ff8dcfe29377088ab655fda9d585dccd5b1f07fabd94ae84fd60a7f8@%3Ccommits.pulsar.apache.org%3E
- https://lists.apache.org/thread.html/r5532dc8d5456b5151e8c286801e2e5769f5c04118b29c3b5d13ea387@%3Cissues.beam.apache.org%3E
More Apache Commons Compress vulnerabilities
- TI-2021-14540 Apache Commons Compress 1.0 to 1.20 denial of service vulnerability CVSS 3.1HIGH 7.5
- TI-2021-14251 Apache Commons Compress 1.1 to 1.20 denial of service vulnerability CVSS 3.1HIGH 7.5
- TI-2019-09249 Infinite loop in Apache Commons Compress CVSS 3.1HIGH 7.5
- TI-2021-14250 Apache Commons Compress 1.6 to 1.20 denial of service vulnerability CVSS 3.1HIGH 7.5
- TI-2021-14249 Apache Commons Compress 1.6 to 1.20 denial of service vulnerability CVSS 3.1HIGH 7.5
- TI-2012-01871 Algorithmic complexity vulnerability in the sorting algorithms in bzip2 compressing… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2018-1324 · CVE Program
- CVE-2018-1324 · NVD
- FIRST EPSS
- GHSA-h436-432x-8fvx · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1324 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences