In Apache Storm 0.10.0 through 0.10.2, 1.0.0 through 1.0.6, 1.1.0 through 1.1.2, and…
Priority MEDIUM 45Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
In Apache Storm 0.10.0 through 0.10.2, 1.0.0 through 1.0.6, 1.1.0 through 1.1.2, and 1.2.0 through 1.2.1, an attacker with access to a secure storm cluster in some cases could execute arbitrary code as a different user.
Why it matters now
EPSS 0.04424 91st percentileScored 2026-11-07
Fix Fixed org.apache.storm:storm-core (Maven): 1.2.2, 1.1.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Storm | 0.10.0 through 0.10.2; 1.0.0 through 1.0.6; 1.1.0 through 1.1.2; 1.2.0 through 1.2.1 | — | No fix listed | CNA |
| — | org.apache.storm:storm-core (Maven) | 1.2.0 to before 1.2.2 | 1.2.2 | Patch available | GHSA-p8jx-x2vw-wm33 |
| — | org.apache.storm:storm-core (Maven) | before 1.1.3 | 1.1.3 | Patch available | GHSA-p8jx-x2vw-wm33 |
- Apache Storm VendorApache Affected 0.10.0 through 0.10.2; 1.0.0 through 1.0.6; 1.1.0 through 1.1.2; 1.2.0 through 1.2.1 Fixed in — No fix listed CNA
- org.apache.storm:storm-core (Maven) Vendor— Affected 1.2.0 to before 1.2.2 Fixed in 1.2.2 Patch available GHSA-p8jx-x2vw-wm33
- org.apache.storm:storm-core (Maven) Vendor— Affected before 1.1.3 Fixed in 1.1.3 Patch available GHSA-p8jx-x2vw-wm33
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:storm:*:*:*:*:*:*:*:* | after 0.10.0, up to 0.10.2; 1.0.0 – 1.0.6; after 1.1.0, up to 1.1.2; 1.2.0 – 1.2.1 | Vulnerable | Apache |
- cpe:2.3:a:apache:storm:*:*:*:*:*:*:*:* Versions after 0.10.0, up to 0.10.2; 1.0.0 – 1.0.6; after 1.1.0, up to 1.1.2; 1.2.0 – 1.2.1 Vulnerable ·Apache
Remediation
- Fix · GHSA-p8jx-x2vw-wm33 org.apache.storm:storm-core (Maven) Fixed in 1.2.2 Advisory →
- Fix · GHSA-p8jx-x2vw-wm33 org.apache.storm:storm-core (Maven) Fixed in 1.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1331
- 2026-10-03 Alias added: GHSA-p8jx-x2vw-wm33
References
Advisory 5
More Apache Storm vulnerabilities
- TI-2021-15907 Shell Command Injection Vulnerability in Nimbus Thrift Server CVSS 3.1CRITICAL 9.8
- TI-2021-17787 Unsafe Pre-Authentication Deserialization In Workers CVSS 3.1CRITICAL 9.8
- TI-2015-02819 The UI daemon in Apache Storm 0.10.0 before 0.10.0-beta1 allows remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2018-08436 Deserialization of untrusted data in Apache Storm CVSS 3.0CRITICAL 9.8
- TI-2017-07179 It was found that under some situations and configurations of Apache Storm 1.x before… CVSS 3.0HIGH 8.8
- TI-2026-27475 Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling CVSS 3.1HIGH 8.8
Sources
- CVE-2018-1331 · CVE Program
- CVE-2018-1331 · NVD
- FIRST EPSS
- GHSA-p8jx-x2vw-wm33 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences