Information disclosure in Apache Spark
Priority LOW 22CWE-200Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.
Why it matters now
EPSS 0.00504 43rd percentileScored 2026-11-07
Fix Fixed org.apache.spark:spark-core_2.10 (Maven): 2.1.3, 2.2.2org.apache.spark:spark-core_2.11 (Maven): 2.1.3, 2.2.2, 2.3.1+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Spark | 1.0.0 to 2.1.2; 2.2.0 to 2.2.1; 2.3.0 | — | No fix listed | CNA |
| — | org.apache.spark:spark-core_2.10 (Maven) | 1.0.0 to before 2.1.3 | 2.1.3 | Patch available | GHSA-6mqq-8r44-vmjc |
| — | org.apache.spark:spark-core_2.10 (Maven) | 2.2.0 to before 2.2.2 | 2.2.2 | Patch available | GHSA-6mqq-8r44-vmjc |
| — | org.apache.spark:spark-core_2.11 (Maven) | 1.0.0 to before 2.1.3 | 2.1.3 | Patch available | GHSA-6mqq-8r44-vmjc |
| — | org.apache.spark:spark-core_2.11 (Maven) | 2.2.0 to before 2.2.2 | 2.2.2 | Patch available | GHSA-6mqq-8r44-vmjc |
| — | org.apache.spark:spark-core_2.11 (Maven) | 2.3.0 to before 2.3.1 | 2.3.1 | Patch available | GHSA-6mqq-8r44-vmjc |
| — | pyspark (PyPI) | 2.2.0 to before 2.2.2 | 2.2.2 | Patch available | GHSA-6mqq-8r44-vmjc |
| — | pyspark (PyPI) | before 2.1.3 | 2.1.3 | Patch available | GHSA-6mqq-8r44-vmjc |
- Apache Spark VendorApache Affected 1.0.0 to 2.1.2; 2.2.0 to 2.2.1; 2.3.0 Fixed in — No fix listed CNA
- org.apache.spark:spark-core_2.10 (Maven) Vendor— Affected 1.0.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-6mqq-8r44-vmjc
- org.apache.spark:spark-core_2.10 (Maven) Vendor— Affected 2.2.0 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-6mqq-8r44-vmjc
- org.apache.spark:spark-core_2.11 (Maven) Vendor— Affected 1.0.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-6mqq-8r44-vmjc
- org.apache.spark:spark-core_2.11 (Maven) Vendor— Affected 2.2.0 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-6mqq-8r44-vmjc
- org.apache.spark:spark-core_2.11 (Maven) Vendor— Affected 2.3.0 to before 2.3.1 Fixed in 2.3.1 Patch available GHSA-6mqq-8r44-vmjc
- pyspark (PyPI) Vendor— Affected 2.2.0 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-6mqq-8r44-vmjc
- pyspark (PyPI) Vendor— Affected before 2.1.3 Fixed in 2.1.3 Patch available GHSA-6mqq-8r44-vmjc
Remediation
- Fix · GHSA-6mqq-8r44-vmjc org.apache.spark:spark-core_2.10 (Maven) Fixed in 2.1.3 Advisory →
- Fix · GHSA-6mqq-8r44-vmjc org.apache.spark:spark-core_2.10 (Maven) Fixed in 2.2.2 Advisory →
- Fix · GHSA-6mqq-8r44-vmjc org.apache.spark:spark-core_2.11 (Maven) Fixed in 2.1.3 Advisory →
- Fix · GHSA-6mqq-8r44-vmjc org.apache.spark:spark-core_2.11 (Maven) Fixed in 2.2.2 Advisory →
- Fix · GHSA-6mqq-8r44-vmjc org.apache.spark:spark-core_2.11 (Maven) Fixed in 2.3.1 Advisory →
- Fix · GHSA-6mqq-8r44-vmjc pyspark (PyPI) Fixed in 2.2.2 Advisory →
- Fix · GHSA-6mqq-8r44-vmjc pyspark (PyPI) Fixed in 2.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1334
- 2026-10-03 Alias added: GHSA-6mqq-8r44-vmjc
References
Advisory 3
More Apache Spark vulnerabilities
- TI-2022-14901 Apache Spark shell command injection vulnerability via Spark UI KEVCVSS 3.1HIGH 8.8
- TI-2023-15314 Apache Spark: Shell command injection via Spark UI CVSS 3.1HIGH 8.8
- TI-2020-07589 Missing authentication in Apache Spark CVSS 3.1CRITICAL 9.8
- TI-2020-16549 Uncontrolled resource consumption in Eclipse Jetty CVSS 3.1MEDIUM 5.3
- TI-2019-14677 HttpObjectDecoder.java in Netty before 4.1.44 allows a Content-Length header to be… CVSS 3.1CRITICAL 9.1
- TI-2018-08427 Improper authentication in Apache Spark CVSS 3.1MEDIUM 4.2
Sources
- CVE-2018-1334 · CVE Program
- CVE-2018-1334 · NVD
- FIRST EPSS
- GHSA-6mqq-8r44-vmjc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences