XML external entity injection in SAP NetWeaver Application Server
Priority LOW 33CWE-611Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
SAML 2.0 functionality in SAP NetWeaver AS Java, does not sufficiently validate XML documents received from an untrusted source. This is fixed in versions 7.2, 7.30, 7.31, 7.40 and 7.50.
Why it matters now
EPSS 0.01107 66th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver Application Server (Java Library) | = 7.20; = 7.30; = 7.31; = 7.50 | — | No fix listed | CNA |
- SAP NetWeaver Application Server (Java Library) VendorSAP Affected = 7.20; = 7.30; = 7.31; = 7.50 Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_application_server_java:7.20:*:*:*:*:*:*:* | 7.20 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_application_server_java:7.20:*:*:*:*:*:*:* Versions 7.20 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-2492
- 2026-10-03 Alias added: GHSA-p72f-5p6w-9jjp
References
More SAP Netweaver Application Server Java vulnerabilities
- TI-2020-05139 Missing authentication in SAP NetWeaver AS JAVA KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02146 SQL injection vulnerability in the UDDI server in SAP NetWeaver J2EE Engine 7.40 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2010-05023 The Invoker Servlet on SAP NetWeaver Application Server Java platforms, possibly before… KEVCVSS 3.1CRITICAL 10.0
- TI-2017-09362 Directory traversal vulnerability in scheduler/ui/js/ffffffffbca41eb4/UIUtilJavaScriptJS… KEVCVSS 3.1HIGH 7.5
- TI-2016-03377 Directory traversal vulnerability in SAP NetWeaver AS Java 7.1 through 7.5 allows remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07786 BC-BMT-BPM-DSK in SAP NetWeaver AS JAVA 7.5 allows remote authenticated users to conduct… KEVCVSS 3.1MEDIUM 6.5
Sources
- CVE-2018-2492 · CVE Program
- CVE-2018-2492 · NVD
- FIRST EPSS
- GHSA-p72f-5p6w-9jjp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences