Path traversal in HackerOne angular-http-server node module
Priority LOW 32CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
angular-http-server node module suffers from a Path Traversal vulnerability due to lack of validation of possibleFilename, which allows a malicious user to read content of any file with known path.
Why it matters now
EPSS 0.01452 73rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed angular-http-server (npm): 1.6.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | angular-http-server node module | All versions | — | No fix listed | CNA |
| — | angular-http-server (npm) | before 1.6.0 | 1.6.0 | Patch available | GHSA-4rvg-955w-h68q |
- angular-http-server node module VendorHackerOne Affected All versions Fixed in — No fix listed CNA
- angular-http-server (npm) Vendor— Affected before 1.6.0 Fixed in 1.6.0 Patch available GHSA-4rvg-955w-h68q
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:angular-http-server_project:angular-http-server:*:*:*:*:*:node.js:*:* | all versions | Vulnerable | Angular-http-server Project |
- cpe:2.3:a:angular-http-server_project:angular-http-server:*:*:*:*:*:node.js:*:* Versions all versions Vulnerable ·Angular-http-server Project
Remediation
- Fix · GHSA-4rvg-955w-h68q angular-http-server (npm) Fixed in 1.6.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-3713
- 2026-10-03 Alias added: GHSA-4rvg-955w-h68q
References
Exploit 1
Advisory 2
Sources
- CVE-2018-3713 · CVE Program
- CVE-2018-3713 · NVD
- FIRST EPSS
- GHSA-4rvg-955w-h68q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences