Path traversal in HackerOne glance node module
Priority LOW 32CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
glance node module before 3.0.4 suffers from a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Why it matters now
EPSS 0.01456 73rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed glance node module (HackerOne): 3.0.4glance (npm): 3.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | glance node module | before 3.0.4 | 3.0.4 | Patch available | CNA |
| — | glance (npm) | before 3.0.4 | 3.0.4 | Patch available | GHSA-2x4q-6jfv-8h9h |
- glance node module VendorHackerOne Affected before 3.0.4 Fixed in 3.0.4 Patch available CNA
- glance (npm) Vendor— Affected before 3.0.4 Fixed in 3.0.4 Patch available GHSA-2x4q-6jfv-8h9h
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:glance_project:glance:*:*:*:*:*:node.js:*:* | before 3.0.4 | Vulnerable | Glance Project |
- cpe:2.3:a:glance_project:glance:*:*:*:*:*:node.js:*:* Versions before 3.0.4 Vulnerable ·Glance Project
Remediation
- Fix · CNA glance node module (HackerOne) Fixed in 3.0.4
- Fix · GHSA-2x4q-6jfv-8h9h glance (npm) Fixed in 3.0.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-3715
- 2026-10-03 Alias added: GHSA-2x4q-6jfv-8h9h
References
More Glance Project Glance vulnerabilities
- TI-2022-09479 Path traversal in glance CVSS 3.1MEDIUM 6.5
- TI-2022-13471 The nlpweb/glance repository through 2014-06-27 on GitHub allows absolute path traversal… CVSS 3.1CRITICAL 9.3
- TI-2018-02744 There is a Stored XSS vulnerability in the glance node module versions <= 3.0.5. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2018-3715 · CVE Program
- CVE-2018-3715 · NVD
- FIRST EPSS
- GHSA-2x4q-6jfv-8h9h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences